Chevrolet Cruze Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
My Cruze has always has issues with accelerating and just always seemed to be turbo issues to me but every time I've taken it in they couldn't duplicate the issue and sent me home so just Thursday my check engine light has come on and stayed on and now my car seems to have little to no acceleration and it acts weird when I'm sitting at a light, I do not have a computer to pull the code to see what it says and I have nothing else on my dash except the light, I don't have the money to put into this car and was hoping I could figure it out before Monday cause I have an appointment with a GM dealer not where I bought the car but a GM dealer none the same and I have been reading about the turbo going bad or something similar, he thinks it's the turbo also but was wondering what everyone else thought
 

·
Premium Member
Joined
·
8,003 Posts
Is the car still under power train warranty? If so, then it probably won't cost you anything (although if the car is out of B2B, the dealer will likely charge you and then refund it once they figure out the problem). I do hope you've kept up on the oil changes.
 

·
Administrator
Joined
·
25,596 Posts
Take it in today.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
Is the car still under power train warranty? If so, then it probably won't cost you anything (although if the car is out of B2B, the dealer will likely charge you and then refund it once they figure out the problem). I do hope you've kept up on the oil changes.

Yes I have kept up on them
 

·
Premium Member
Joined
·
5,535 Posts
Since you posted in the 1.8 section but indicate a turbo concern......what engine do you really have?

Rob
 

·
Premium Member
Joined
·
8,003 Posts
Since you posted in the 1.8 section but indicate a turbo concern......what engine do you really have?
The reason that Robby asks is that the 1.8 (most LS trim models) doesn't have a turbo. The 1.4 (LT/LTZ) does.
 
1 - 10 of 10 Posts
Top