Chevrolet Cruze Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter · #1 ·
So the check engine light has switched on again in my 2016.5 Cruze. Probably the same O2 sensor error (P015B) as the last 2 times. Looks like the ECU update didn't resolve or its caused another issue. 3rd time now. My Aveo sh!tbox and Equinox didn't give me as much grief as this car.

Another trip to the dealer I guess and more wasted time. I baby this car and only use Shell premium gas.

Does GM even know what causes this issue?
 

·
Premium Member
Joined
·
5,638 Posts
I don't know if you see all those GM J.D. Powers commercials touting all the awards Chevy has won in recent years but the CRUZE never appears in the award winning lineup. On my second day with the new 2014 all the lights lit up, it started nonstop chiming, and the DIC displayed the words: Serious Engine Fault, Turn off Engine Immediately! Got it fixed right the first time and the car's been decent ever since
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #3 ·
So the SES (service engine soon) light turned itself off tonight. I haven't had a chance to bring it to the dealer yet. Not sure what's going on. Will keep an eye on it.
 

·
Registered
Joined
·
9 Posts
So the SES (service engine soon) light turned itself off tonight. I haven't had a chance to bring it to the dealer yet. Not sure what's going on. Will keep an eye on it.
My 2016.5 had a similar issue with the engine light coming on occasionally. I took it to the dealer a few days ago and they found code p015b. They reprogrammed the ECM per service bulletin 17-NA-155. I hope this is the new programming to prevent the O2 sensor issue.
 
1 - 4 of 4 Posts
Top