Chevrolet Cruze Forums banner
Status
Not open for further replies.
761 - 780 of 799 Posts

·
Banned
Joined
·
1,123 Posts
Yes, you are absolutely right! I am in the process of generating a letter to the general manager of my dealership to recognize the individuals who supported me through this process.
You should send a copy to Akerson too! Maybe it will do some good OR maybe even make him aware of the problem to begin with!
 

·
Premium Member
Joined
·
4,651 Posts
fastdriver said:
You should send a copy to Akerson too! Maybe it will do some good OR maybe even make him aware of the problem to begin with!
steve333 said:
Akerson is a moron. If he didn't initiate action by now himself it's clear he couldn't care less about GM or its customers. He's got his millions for mediocrity
You guys are hilarious… why on earth do you think the CEO of one of the world's largest companies would have a quality control issue like this on their radar? The CEO is not paid to deal with things like this, he is paid to manage the HUGE firm known as General Motors. Ackerson would be doing a great diservice to the 200,000+ employees of GM if he were to get sidetracked into this stuff. There are many layers of management between him and this issue, the bottom of which are the ones who are supposed to look after these types of things.

If you wish to comment on this, send me a PM. Please don't further dilute this otherwise constructive thread.
 

·
Premium Member
Joined
·
25,595 Posts
Yesterday our 8th winter storm since the beginning of March blew in and this morning it was in the low 20s with 3-4 inches of snow on the roads. I had to turn my heater down - not for odor, but because it was sweating me out of my car. At this point I have tested my A/C, all the vents options, blower speeds, and heater and can safely say my car is finally odor free.
 

·
Registered
Joined
·
105 Posts
Nice! I am taking mine back in tomorrow to have them look at the cooling system again. I get the stinky smell in the engine compartment and my garage smells nasty for a few hours after shut down. Coolant level is down to the 2nd (from the bottom) mark and was filled last time it was in for this problem- about 2-3k miles ago.

I will show them some clips from this thread and big kudos to BSM for helping figure out a resolution. I am going to ask them to replace the surge tank and cap to see if it solves my problem. Wish me luck... :hope:
 

·
Premium Member
Joined
·
4,651 Posts
I am going to ask them to replace the surge tank and cap to see if it solves my problem. Wish me luck... :hope:
Before getting the tank replaced, check the inside of the cap area for a rough surface where the o-ring sits. If the surface is smooth and a new tank/cap fixes your problem it was probably the cap. If the tank has a rough spot and the problem gets fixed, it was probably the tank. See pics earlier in the thread. Either way I hope you get the problem sorted out!

I replaced my tank on the weekend and have had no venting since. This is with the coolant properly topped up and still using the OLD cap. I picked up a new cap just as insurance but have yet to put it on.
 

·
Registered
Joined
·
225 Posts
Nice! I am taking mine back in tomorrow to have them look at the cooling system again. I get the stinky smell in the engine compartment and my garage smells nasty for a few hours after shut down. Coolant level is down to the 2nd (from the bottom) mark and was filled last time it was in for this problem- about 2-3k miles ago.

I will show them some clips from this thread and big kudos to BSM for helping figure out a resolution. I am going to ask them to replace the surge tank and cap to see if it solves my problem. Wish me luck... :hope:
Hopefully your service department will get things right for you. I do want to give credit where credit is due and commutertg and his dealership deserve the credit for discovering the HVAC lube issue. Thanks for the kudos, it was this community that kept me motivated and determined to help figure out the engine compartment issue with my car. Hopefully, this thread will help you and your service department get your engine compartment smell issue under control. As Blue Angel posted, check your tank and cap. I happened to "stumble" across a cap problem (speculating it was bad O-rings) after I replaced my tank and cap. I noticed that my coolant smell literally dissipated after I replaced both. Silver Streak had a great idea to swap caps out and see what surfaces. After I swapped out my cap and put the old one back on the coolant smell returned. So, as you can see much credit goes to other members who have had great suggestions, ideas, and successes in troubleshooting and overcoming this "smell" issue. I do think there is enough information on this thread to help anyone troubleshoot the problem and find a solution. Glad you are using the resources off this forum to help you and possibly your dealership.
 

·
Registered
Joined
·
110 Posts
I can't wait till I can stop posting in this thread!!

I dropped my car off today for the dissapearing coolant issue, and the oil leaking from throttle body after new engine install.... oh and to get the scratches taken care of that happened while the engine was getting installed (right rear quarter...?)

and when i called at 4 to see if they were delivering me 'the rental' or my car, they said they had put a call into hotline(ford term, i'm not sure what they call it at GM) and would call me back when they have a resolution!!

My dealer has been pretty good with me up until very recently. they'd give me a rental when needed or at least give me a ride to work and deliver which ever car to me, but today they dropped off my car, and the poor parts guy asked for a ride back to work. I was shocked that they didn't send someone to pick him up (like last time) so the ford parts guy had to drive the GM parts guy back to his dealer haha.

And they did a full detail on the outside of the car, i know this because they left wax all over the **** car (white car, fair enough) and it's quite obvious now that the scratches are actually dented and the car needs paint now....

so i'm at a loss now. as taylor swift would say, this is exhausting. I hate this car soo much now, if and when they do fix it i will always hate it. They've had the car more than I have in the last 2 months and I'm worse off now than before!
 

·
Premium Member
Joined
·
4,651 Posts
They've had the car more than I have in the last 2 months and I'm worse off now than before!
There's no excuse for the lack of customer service, and definitely no excuse for scratching/denting your car. That's BS. You should be in touch with GM Canada and tell them about two things... 1. your less than satisfactory dealership experience, and 2. the fact that you've had the car in several times for each of multiple complaints.
 

·
Banned
Joined
·
1,123 Posts

·
Premium Member
Joined
·
4,651 Posts
...I did a good bit of stop and go "city" type driving today without the heater on so the car got good and hot. I'm happy to say that, based on today's driving, I have not smelled any coolant with the new tank. A little more time will be necessary before confirming the fix, but it certainly seems good so far.
Well, ten days later, the weather is in the mid-high 20's C (~80F), and I have yet to catch a single wiff of coolant vapor, either inside the car, outside the car, or under the hood. I washed the car tonight and did a quick wash under hood as well. The vent cover on the side of the tank is bone dry without a trace of condensation or dry coolant... no venting has taken place since the tank swap.

I now feel very confident in saying that my personal coolant smell issue, though slight compared to some, was solved by replacing the surge tank with a new one with no defect in the cap seal area.

I would urge anyone with an underhood or outside the car coolant smell issue to go to the dealer and request a new surge tank that does not have any defects as pictured in my previous threads. Since BigSkyMontana appears to have had his issue cleared up by replacing the tank cap, it wouldn't hurt to suggest to your dealer to install both a new tank and cap. I installed a new cap as well, but that was days after my tank swap and I had no odors using the old cap with my new tank.

For those who are having HVAC lube related odor issues (the ones that seem to come and go based on heater use and vent position), there is a fix involving the replacement of the HVAC case with a new one that uses a new lubricant that does not smell when heated.

If you have issues that are resolved at the dealer, please post your experiences and what fix was performed to cure your issue. The more info we have the better!
 

·
Registered
Joined
·
105 Posts
My dealer changed out my tank and cap per my request via this thread. So far, the smell is improved, but I still have it in the engine bay & my garage. I'll try dropping the level from the max level down to min and see if that helps...
 

·
Registered
Joined
·
75 Posts

·
Premium Member
Joined
·
4,651 Posts
My dealer changed out my tank and cap per my request via this thread. So far, the smell is improved, but I still have it in the engine bay & my garage. I'll try dropping the level from the max level down to min and see if that helps...
milehigh, did you check the inside of the surge tank for defects as per the pics in my previous posts? If the cap seal is functioning properly there should be no venting of coolant vapor at all so lowering your coolant level may not change anything. An easy check for venting is to look at the vent cover on the tank (the little plastic "deflector" pointing away from the cap on the driver's side). If that vent cover is dry and there are no signs of dried coolant (whitish orange deposits) then the tank is not venting.

One thing to keep in mind; if the surge tank was just replaced there is most likely some coolant that was spilled inside the engine bay. This coolant will emit an odor until it is completely dry. It may help to take a hose and gently rinse the engine compartment, paying attention to rinse the top of the transmission and all other items around the surge tank. If your underbody shield has not been cut per the recall there could be coolant pooled up there as well.

Use a gentle shower setting on the sprayer nozzle if possible; it is not recommended to use a high velocity spray under hood as this could force water into wiring connections. A gentle but thorough rinse is completely safe and may get rid of that last little bit of colant smell. The dealer should have done this when the work was completed, but I wouldn't be surprised if they didn't.

Even without rinsing the smell of any spilled coolant should pass after a few days of driving the car, if spilled coolant is the source of the smell.
 

·
Premium Member
Joined
·
4,651 Posts
I still find it interesting that all the other GM cars thst use the 1.4 turbo have the surge tank in the front of the engine compartment.
I don't think there's anything worth reading into there... it's just packaging. The surge tank is just a reservoir; all the heat producing items in the coolant's path are what will affect the system. As long as they're able to place the surge tank above the coolant level in the rest of the system (highest point) I don't think it matters where the tank is located.


Sent from AutoGuide.com Free App
 

·
Banned
Joined
·
40 Posts
I had my car fixed of this problem I have a 2012 Cruze RS 6MT noticed a smell after i parked my car walking into the house, so i checked and I was down a full line gap from full took it in they couldn't tell at the time but could smell it so they filled it up with some dye in the coolant took about 4000 km to be down enough to take it, which was in between the full line and the second line down. they looked at it, had to take all the pulley's off to see the small leak on the water pump seeping out to me what looks like a frost plug on the water pump itself but was not a frost plug obviously, they swapped me out a new pump had to take maybe another 5000km for the smell to go away under the hood, but seems good so far "knock on wood" and I've gone about 10,000 k since the fix hope this helps anyone with the problem, mine was a very slow leak if I knew nothing about cars It probably would have gone unnoticed for a while..


Sent from AutoGuide.com Free App
 

·
Premium Member
Joined
·
4,651 Posts
I had my car fixed of this problem... ...had to take all the pulley's off to see the small leak on the water pump... ...take maybe another 5000km for the smell to go away under the hood...
Great to hear of another successful fix!

You bring up an excellent point about the smell taking a while to go away after the work was done. I will re-state in bold for everyone's benefit:

AFTER HAVING ANY SERVICE DONE TO YOUR CAR'S COOLING SYSTEM, ASK THE DEALER TO RINSE THE ENGINE COMPARTMENT. Any spilled coolant will hang around and smell for quite some time after the fix is complete. This can make it seem that the problem was not corrected!

If they resist, tell them you don't need them to wash and detail the engine, just a quick rinse to get rid of any coolant left hanging around.

I used to work at GM Oshawa Plant and grew up in Port Perry. I moved to Ottawa a few years ago.
 
761 - 780 of 799 Posts
Status
Not open for further replies.
Top