Chevrolet Cruze Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I cannot get Apple Carplay to work. In the car settings I have Carplay turned on, in my phone I have Carplay enabled, but the car display keeps saying connect device through USB. The USB will charge my phone but nothing else. I've rebooted phone and restarted car, and tried another iPhone and multiple official Apple cables but no luck. Any ideas?
 

·
Resident Forum Drunkard
Joined
·
9,273 Posts
HTML:
Walk around the cruzen and kick all 4 tyres to show IT whom ls boss ..

If that don't work . Take IT back to the dealer of yer choice ...:party:
 

·
Epic Beard Man
Joined
·
5,389 Posts
Walk around the cruzen and kick all 4 tyres to show IT whom ls boss ..

If that don't work . Take IT back to the dealer of yer choice ...:party:
Or take another bite out of the apple ?
 
  • Like
Reactions: brian v

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
Pretty sure the USB port is just broken. I also tried with an Android phone and same result. Putting in a USB thumb drive with music on it results in the USB option is source being greyed out and unable to select. When I plug a phone in, power is sent to charge the phone, and the light on the USB drive flashes once when inserted but no devices are recognized. I suppose the data pins in the port are compromised but not the power part. Still under warranty so hopefully they can just pop a new port in there; I think it's a removable part.
 

·
Registered
Joined
·
300 Posts
Mine has failed twice now. I use Android Auto, but the symptoms are the same: USB port charges, but won't make a data connection.

After the first failure, the dealer was instructed by GM to test the port and the wiring, but ultimately ended up replacing the head unit. Problem solved for a little over a month.

I'm kind of happy to find that I'm not the only one. I was starting to get paranoid that I was doing something to cause it.
 

·
Registered
Joined
·
296 Posts
check if there is something stuck inside the USB port that prevents it from communicating properly with your smatphones.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
Yeah they just put a whole new head unit in mine too. I really don't care about the Carplay part, I mostly just need the USB port for my music which now works!
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top