Chevrolet Cruze Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
hey guys im havin some troubles with my gen 1 cruze with the 1.4 i keep getting boost pressure sensor and intake air temp codes what could cause these?

all i have done is a cold air intake from spectre n thats it
 

·
Registered
Joined
·
296 Posts
all i have done is a cold air intake from spectre
And that is all it takes. This site gets a constant stream of people with "cold air intake" related issues. Although admittedly your issue is different than other peoples issues. I believe that your issue was caused either from the installation or use of the aftermarket intake. You may have damaged the sensor wires. Or the problem is from the MAF getting bad readings. On some GM vehicles the MAF and IAT reading are integrated for a input to the ECM. I think what you are seeing is an odd MAF reading fooling the computer into thinking the intake air temperature must be wrong.

I'm putting this in here mainly for anyone reading considering a "cold air intake". Your car already has a cold air intake. What you are buying is a short ram intake that will make your car slower and in most cases cause it run poorly. For any aftermarket intake to be of benefit you need the car tuned to that specific intake.

Put the OEM intake back on, return the Spectre if you can. Get back to us if you still have issues.
 

·
Premium Member
2013 Cruze LT
Joined
·
3,629 Posts
Is the aftermarket filter taking air in from the engine compartment or fender? If it's the engine compartment, you have a "hot air intake"
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #5 ·
i put a new boost presure sensor in n happend to take care of boost code n workin on cleaning my air filter to see if changes anything
 

·
Premium Member
2013 Cruze LT
Joined
·
3,629 Posts
Yep. I have a zzp intake and it’s 80 degrees out and sunny. Intake temps are in the 120s range which is terrible it loses lots of torque
Yep, they market it as a cold air intake, always makes me laugh a little bit. Stock intake is going to 100% bring in cooler air from the fender/front bumper.
 

·
Premium Member
2013 Cruze LT
Joined
·
3,629 Posts
i put a new boost presure sensor in n happend to take care of boost code n workin on cleaning my air filter to see if changes anything
Thanks for the update, let us know the outcome!
 

·
Registered
2014 RS
Joined
·
62 Posts
Best bet is to go with the K & N slab filter replacement. Beats the snut out of any so-called "cold air intake".
 
1 - 8 of 8 Posts
Top