Chevrolet Cruze Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
Ok i have a 2012 Chevrolet Cruze eco 1.4t its a flooded title but evreything works I installed a boost gauge and it only marks 6psi and the vacuum its around 17-18-20 and i check for boostleak and cant find any and a get the code p2306 the boost sensor was change and put a new one and that was not it and car is a 6 speed MT from time to time it would go up to 16 psi and once you stop it wont do it again can anybody help should i take it to Chevrolet would they fix the problem or a local shop
 

·
Moderator
Joined
·
2,170 Posts
Ok i have a 2012 Chevrolet Cruze eco 1.4t its a flooded title but evreything works I installed a boost gauge and it only marks 6psi and the vacuum its around 17-18-20 and i check for boostleak and cant find any and a get the code p2306 the boost sensor was change and put a new one and that was not it and car is a 6 speed MT from time to time it would go up to 16 psi and once you stop it wont do it again can anybody help should i take it to Chevrolet would they fix the problem or a local shop
What type of boost gauge?
 

·
Administrator
Joined
·
25,596 Posts
Doesn't P2306 point to the ignition rail and/or spark plugs?
 

·
Premium Member
2014 Cruze Diesel, 2007 Cobalt, 1981 Camaro Z28, 2017 Volt
Joined
·
5,913 Posts
If it had made it up to 16psi before, then you don't have a boost leak.

This is what I'm seeing P2306 as: "Ignition Coil C Pri Ctrl Circ Low"
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top