Chevrolet Cruze Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
11 Cruze 1.4 with 150,000 miles with the intake check valve fix. Around 130,000 miles I started having an issue where I got a CEL for low boost when I would run high octane gas. It would go away when I ran regular gas. At 145,000 miles I replaced the turbo since I knew they have known issues and it was the original turbo. The old turbo was cracked (normal wastegate area) and the rod completely loose/worn out. Thought it would solve my problem but now I get a CEL for low boost all of the time. Even if I clear it. I have air tested my system, and fixed a few small leaks but still have the CEL for low boost. Any ideas? Is there a way I can monitor my actual boost levels while driving with the computer (torque app) or do I need to install a mechanical guage?

It seems like when the car is cold, it is much snappier than when it's warmed up.
 

·
Super Moderator
2014 LT program car, Pull Me Over Red
Joined
·
8,429 Posts
11 Cruze 1.4 with 150,000 miles with the intake check valve fix. Around 130,000 miles I started having an issue where I got a CEL for low boost when I would run high octane gas. It would go away when I ran regular gas. At 145,000 miles I replaced the turbo since I knew they have known issues and it was the original turbo. The old turbo was cracked (normal wastegate area) and the rod completely loose/worn out. Thought it would solve my problem but now I get a CEL for low boost all of the time. Even if I clear it. I have air tested my system, and fixed a few small leaks but still have the CEL for low boost. Any ideas? Is there a way I can monitor my actual boost levels while driving with the computer (torque app) or do I need to install a mechanical guage?

It seems like when the car is cold, it is much snappier than when it's warmed up.
How long have you had the fix? Do you have th Bonomi valve? It may need to be cleaned.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
No, at least I dont think so. I just added the manifold check valve fix

Edit: I guess I do have that valve. I'll pull it and clean it.
 
1 - 3 of 3 Posts
Top