Chevrolet Cruze Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
I have a Chevy cruze 2011 my car would not start. All of the lights would come on but the car would not start. There were no click sounds just the all the lights on the dashboard would come on.
I took the car to the Chevy dealership to get it diagnosed. The diagnose did not tell them what is wrong with the car. They said it could be the key programming in the remote. So they reprogram my key and the car still would not start. They then said after test everything it could only be the module for the ECM, my ECM was bad. They charged me over $700 for what they believe may be wrong with the car.
A few weeks later it happened again the car would not start but if I waited a few minutes it would eventually start. I called the dealership informing them I am having the same issues. The car was doing the same exactly thing, all lights on but not start.
Yesterday my car would not start. I waited the few minutes and it still did not start. start. After a few hours later I had the car towed to the dealership. They checked out the car and said it is the starter, so with parts and labor over $500.
I asked would it had being the starter the first time if its the starter now. They said no. It was the ECM then and now it is the starter.
I do not know what to do?
 

·
Premium Member
Joined
·
25,596 Posts
Find a different dealership ASAP. This one is just throwing parts at the car and not actually trying to diagnose the problem. Question, has the negative battery cable been replaced under the 10 year 120,000 mile extended warranty for the cable? If not get this done before any other electrical system diagnostics.
 

·
Premium Member
Joined
·
25,596 Posts
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top