Chevrolet Cruze Forums banner

61 - 68 of 68 Posts

·
Registered
Joined
·
1 Posts
My 2015 Chevy cruise, emission Light went on also at 82000Miles and again it was Catalytic converters, and they said not covered as well, the warranty is 80,000 or 8years which ever comes first
How Ironic both at 82000 and WEIRD
 

·
Super Moderator
2014 LT program car, Pull Me Over Red
Joined
·
7,936 Posts
My 2015 Chevy cruise, emission Light went on also at 82000Miles and again it was Catalytic converters, and they said not covered as well, the warranty is 80,000 or 8years which ever comes first
How Ironic both at 82000 and WEIRD
Welcome Aboard:welcome:

Don't forget to introduce yourself and your Cruze here.

What is the code?
 

·
Registered
Joined
·
2 Posts
I had this code too. First tried cat clean it went away and a month later came back. Changed the o2 sensors came back. So I went ahead and changed the catalytic converter. Couple weeks later came right back. So I found these o2 spacers on eBay it even says code fixer or whatever. Put the spacer in front of the back o2 and it’s been 5 months nothing yet. My father in-law had the same code for his Toyota Sequoia did the same thing code gone.
 

·
Registered
Joined
·
55 Posts
I had this code too. First tried cat clean it went away and a month later came back. Changed the o2 sensors came back. So I went ahead and changed the catalytic converter. Couple weeks later came right back. So I found these o2 spacers on eBay it even says code fixer or whatever. Put the spacer in front of the back o2 and it’s been 5 months nothing yet. My father in-law had the same code for his Toyota Sequoia did the same thing code gone.
Do you have a link to what you used?
 

·
Registered
Joined
·
2 Posts
It's been a while since I've posted here. Sadly, it's not for the better

My 2013 Cruze 1.4 had the check engine light come on. Took it to the delership and said the catalytic converter has gone bad. I have 82k miles, and the dealership says it is NOT covered by my extended care warranty. Said it would cost $1400 to repair. Anyone else had this happen to them?
Yes. I have had this exact problem. I have a 2013 Cruze 1.4 turbo LTZ RS and the cat went out at 35k miles. $1200 job. Under warranty, so no biggie. However, it also went out again at 90k, out of warranty. Because I already had it replaced, they are giving me a break on the cost, but it's still going to run me $575.

What the hell!!! I'm 55, so this is like my 20th car. I've NEVER had a cat fail in any car I've ever owned. Now I've had TWO go bad in the same car? Under 90k miles??? This is nonsense. I smell a class-action coming their way.

And as others have posted, they are quoting me many weeks before we can get one, so I know it's a system-wide issue.
 

·
Registered
Joined
·
1 Posts
I have a 2013 Cruze (99,000 miles). I got the P420 code and the check engine light pop up. I had an aftermarket cat put in (local garage) and still had the check engine light pop up. They replaced the new cat free of charge. Ended up getting another check engine light with the same code! Brought it to the dealership I got the car from and they did a software update. Check engine light still came on a month later. Dealership says the aftermarket cat that was installed isn't working properly and will require a new OEM cat ($1,177). Local mechanic says that these cats should work and believes that the cars computer is having problems and that the dealership should fix it. Any suggestion how I can best approach this problem?
 
61 - 68 of 68 Posts
Top