Chevrolet Cruze Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 · (Edited)
Hi everyone,

I'm hoping for a little guidance about my 2011 Cruze Eco M6 before I take it to a dealer. On Friday, I was commuting when I glanced down and noticed the CEL was on. I took it to Autozone over the weekend to have the code scanned, and it came back with P0171: running lean. The car runs fine, but it idles hard. It seems to fluctuate between 650 and 1,000 RPMs at idle.

In doing some research this morning, I learned that it could be the oil cap and/or dipstick, so I checked those and they were both right where they should be. The only thing I can think of that could have made a difference is that we recently had a blizzard and the streets were littered with ice craters and divots, so it was a really bumpy ride for a couple of days. I guess I might have jostled something loose...

Does anyone have any other suggestions for things to check? Could it be an O2 sensor? Is there a way to test the O2 sensors without removing them? I have a decent amount of mechanical aptitude; I think I could change an O2 sensor myself. Damned if I'm going to pay some other guy $80/hour to do it for me...
 

·
Premium Member
Joined
·
1,943 Posts
Where did you come up with oil cap or dipstick??? Maybe want to check for:
dirty/faulty MAF
vacuum leaks
cracked vacuum or PCV line/connection
faulty O2 sensor (bank 1 sensor 1)

On a side note.........congrats on your 1st post in 3 years! :th_dblthumb2:
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks, that link is super helpful!

Looks like the first O2 sensor is a possible cause, but I can check those other things first. Any idea if this is a common problem with our cars?
 

·
Administrator, Resident Tater Salad
Joined
·
17,353 Posts
This code is usually a vacuum leak in my experience.

You may have a bad PCV valve in the valve cover. Do you hear a hissing sound and/or see oil in the intake tube/have been losing oil?
 

·
Premium Member
Joined
·
906 Posts
This code is usually a vacuum leak in my experience.

You may have a bad PCV valve in the valve cover. Do you hear a hissing sound and/or see oil in the intake tube/have been losing oil?
J is spot on.. When my PCV valve went out the symptoms that you are having is exactly what mine was doing..


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #7 ·
Thank you for all of your responses, everyone. I ended up opening the hood and staring blankly at the engine for a while...I noted that there were no obvious loose or damaged hoses, then admitted to myself that I don't know the first thing about diagnosing engines. Thankfully, a dealer nearby doesn't charge for the first hour of diagnostic, so I took it there to have them take a look. The problem was that the valve cover was leaking, which was causing misfires. Never in a billion years would I have arrived at that conclusion on my own. In any case, the repair is covered by the warranty and I just wanted to thank all of you that offered your suggestions.

Cheers.
 

·
Chevrolet Customer Assistance Representative
Joined
·
5,722 Posts
three.one.seven,

I am glad to hear you were able to have your concern resolved. Happy driving!

Erica Tiffany
Chevrolet Customer Care
 

·
Registered
Joined
·
31 Posts
Just had the Dealership look into a P0171 code and sure as s**t, vacuum leak, it was a cracked valve cover.
 

·
Registered
Joined
·
11 Posts
Here's a video on how to replace the cover if you ever have to end up doing it out of warranty. Took me about 20 min
 

·
Registered
Joined
·
1 Posts
I also have a 2011 Chevy Cruze ECO with this same error code. But mine is not hissing just dies while I am driving. Could this be something other than the valve cover? It actually gave 4 of the same code. And also the p0174.
 

·
Registered
Joined
·
74 Posts
Mine doesn't hiss just yet but gets the P0171 code. Has ruff idle at times, all other connections are fine... I just bought the cover today and will replace it tonight. I know it's covered under 5yr-100k but I don't have time to wait at the dealers.
 
1 - 13 of 13 Posts
Top