Chevrolet Cruze Forums banner

1 - 4 of 4 Posts

·
Patience Of Job
Joined
·
562 Posts
Discussion Starter · #1 ·
Well I got a strange occurrence today, while I am driving I get the dreaded CEL light on. So continue to run my routine drives & decide to drop by the Auto zone & let them run it once I am near there, well I had to make a few stops & turn the engine off & re-start well the engine light stayed on all the during the times, until my last stop I get back in & start the car the engine light goes off.

So I figured I would drop in & get it scanned to see in the memory bank what might be there, just to be safe. Well I did & it seems they came out w/ like "lost communication with BCM" "brake pedal positioning sensor" & "MAF Sensor" ok that last one made me think as it was there a couple times, I remember my car is missing somewhat, idling somewhat rough & so forth, so I am thinking maybe that is going bad?

My main question is should I be concerned even after the light went back off & hasn't came back on for another few start cycles & if its the MAF sensor which it maybe it will come back on & stay on after it completely flakes out? Also what about the lost 2?, like lost communication with BCM? & brake pedal positioning sensor? Advise?
 

·
Resident Forum Drunkard
Joined
·
9,307 Posts
You working on yer cruzen now ?

There is a mass air flow sensor cleaner that comes in a spray can and that is about all you can do for that part other than changing the whole assembly out for new .
Those other 2 are part of the 2 Gremlins ya have images (1).jpg Good Luck .
 

·
Patience Of Job
Joined
·
562 Posts
Discussion Starter · #3 ·
Yes I have already cleaned it about a week ago using a CRC MAF sensor cleaner. So I am going to wait til it lights up again & get a good reading & change it out completely. Now w/ the other two issues the BCM & the brake pedal position sensor - those are stored within the system but I am sure in time those will cause the CEL to light up.

The only real concern I have is the "lost communication with BCM" the other two are fixable by me easily but w/ the BCM I am lost.
 

·
Registered
Joined
·
533 Posts
Yes I have already cleaned it about a week ago using a CRC MAF sensor cleaner. So I am going to wait til it lights up again & get a good reading & change it out completely. Now w/ the other two issues the BCM & the brake pedal position sensor - those are stored within the system but I am sure in time those will cause the CEL to light up.

The only real concern I have is the "lost communication with BCM" the other two are fixable by me easily but w/ the BCM I am lost.
FWIW, I had a pending "lost communication with the BCM" code once. Also (on a separate occasion) got a "ECM lost communication with TCM" code. The BCM one I never noticed outside of seeing the code, I believe it was a fluke. The TCM one I definitely noticed. But it also only came up once. I cleared the BCM code and it never came back. Not sure about the brake pedal sensor.


Sent from AutoGuide.com Free App
 
1 - 4 of 4 Posts
Top