Chevrolet Cruze Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 · (Edited)
I have a 2012 Chevy Cruze. 1.4L turbo with around 24,800 miles (i'm past the 3 year warranty) on it. I have been in two accidents (the first one was three years ago), but after the most recent one I was hit behind which is when I started experiencing all these problems. After the accident (maybe a few weeks), my battery died randomly after coming back from the store. "Service Stabili trak" and "power steering" came on and then went away. Had it jump started and it worked fine for a few weeks. I also had the battery checked at Firestone and they said it was like a brand new battery and that it was fine. I'm assuming I may have just left something charging or on.

Went and got my car repaired 2 weeks ago from the accident (bumper damage and the impact bar) and now the engine light came on yesterday while driving.
At times when I'm slowing down at a red light the car feels like it's struggling a bit (it feels like it's about to die on me). I went today to Chevrolet to get some recalls done which I thought might have been the problem (one of the recalls involved the "service stabili trak...etc signs" and the other was involving the engine coolant. Was told the recall got rid of one of the codes, but a few other codes showed up. I have had the engine light show up once about a year ago when I was driving but I turned off the car and when I turned it back on it was gone so I never thought much of it.

I don't have the codes on me at the moment but I will edit this post and post them up when I get home from work in a few hours.

I'm just curious if you guys might know what's going on? I'm a bit surprised this is happening cause before the accident my car was running fine. I've never really had any problems with my car before.

I appreciate the help!

Also, I hope this is the correct section to post this. Please let me know if it's not~ Thank you!


UPDATE: While driving home, the light for traction control came on and "Service StabiliTrak" as well as "Service Traction Control" came on the screen...
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #5 ·
Update~
While driving home the traction control light came on and "service stabilitrak" and "Service traction control" came on the screen.

I did two recalls today at the dealer. They did recalls 14801 (Emission recall, reprogram engine control module) and 14417 (Low engine coolant level without an external leak)

As for codes, they cleared codes WCC for programming: 11D59, WCC for Setup: FDB32

They found the codes for the check engine Light: P0171, P0106, P1101, U0237, B1325

I have a paper for a recall that seems to be related to the problems I'm getting. Looks like it's the negative battery cable. I'm gonna go in tomorrow and get that recall hopefully done. I'm hoping all the other codes are related to this recall because as I said, my 3 years warranty ran out on me,

p.s. XD It wasn't my fault though T_T
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top