Chevrolet Cruze Forums banner

1 - 20 of 38 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
Ugh driving home today and while looking down as my car was coming back from autostop I noticed the check engine light come on. I was like ugh hopefully not the same code from back from January this year. Ringed up Onstar to run an on demand scan and code P015B :-(
Dealer replaced the heat oxygen sensor back on Jan 9th with only 3,330 miles on. The service manager told my the sensor was fried. I was a little sour the first time having a check light so soon, ughing more now about it now at 5,530 same code. Going to be taking it in tomorrow to get fixed up. I have noticed over the past few weeks at random idle seem not to be smooth. Also twice in the past 3 weeks while stopped at a light can't think how to describe it, but felt like car turned on again and off then on. But looking down at the gages they were normal and was not in auto stop mode. I have had a few times that it seems like the car wants to go into auto stop then it will but instantly turns back on. Wondering if fun auto stop is killing this sensor.

2017 Cruze
 

·
Registered
Joined
·
42 Posts
Discussion Starter #2 (Edited)
My car spent the night at the dealer. I brought it in first thing yesterday morning. Guessing they were busy since I did not hear any updates at all yesterday. When I called 2 hours before closing was not able to reach anyone and text my service advisor and he got back to me mid morning telling me my car was not worked on yet. Then a few hours a text back everything was all fixed and it was the O2 Sensor. Just went to go pick it up and my service advisor was gone so I went over to the cashier. reviewed paperwork same part replaced as last time and I was on my way. When I got home I walked over to the mail box and walking back I was like dang my car got hit by birds again. Had a problem getting bombed really nice 3 days straight. When I got closer, I noticed some nice fun damage to my bumper. I called the dealer up and was told to return tomorrow to talk with the service manager. Something tells me this is going to turn into a pointing finger conversation.

I do have another scuff on the lower bumper side near the wheel well, which is my fault for being dumb. Was not going to even mention I want that fixed when they fix the damage I got while I was at the dealer. But wondering if I should.

Any advice when talking with the service manager tomorrow? I m hoping it should be as easy as, This happened when my car was in for check engine light work, can my bumper get fixed up please.



Cruze.jpg
 

·
Registered
Joined
·
9 Posts
How did it go?
My car spent the night at the dealer. I brought it in first thing yesterday morning. Guessing they were busy since I did not hear any updates at all yesterday. When I called 2 hours before closing was not able to reach anyone and text my service advisor and he got back to me mid morning telling me my car was not worked on yet. Then a few hours a text back everything was all fixed and it was the O2 Sensor. Just went to go pick it up and my service advisor was gone so I went over to the cashier. reviewed paperwork same part replaced as last time and I was on my way. When I got home I walked over to the mail box and walking back I was like dang my car got hit by birds again. Had a problem getting bombed really nice 3 days straight. When I got closer, I noticed some nice fun damage to my bumper. I called the dealer up and was told to return tomorrow to talk with the service manager. Something tells me this is going to turn into a pointing finger conversation.

I do have another scuff on the lower bumper side near the wheel well, which is my fault for being dumb. Was not going to even mention I want that fixed when they fix the damage I got while I was at the dealer. But wondering if I should.

Any advice when talking with the service manager tomorrow? I m hoping it should be as easy as, This happened when my car was in for check engine light work, can my bumper get fixed up please.



View attachment 262969
Sent from my RS988 using Tapatalk
 

·
Registered
Joined
·
42 Posts
Discussion Starter #4
Much delayed response. It took a few weeks of going back and forward and calling every few days and getting I need to talk to the owner to see video tapes but then I finally got a phone call asking me to bring it in and they took care of it. Wish they would have fixed my scuff that was my fault but they only fixed what they messed up. I did get a dealer loaner Trax with only 50 miles on it for a day and a half, was kind of impressed with how it drove. My car did have a strong paint smell in it for a few days was not expecting it, I did not complain and dealt with it, almost smelled like they painted inside the car. I am happy the service manager kept his word saying if was our fault we will take care of it. Just frustrated that it happened and having to keep on them.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #5
welp just had this occur again third time. The funny thing this happend for the first time today. Now that this has happened 3 times now it has me worried and with only 1 year left on bumper to bumper warranty. Since I think this would only be fixed free under bumper to bumper. Ill contact the dealer tomorrow to get this fixed. Almost wondering if I can ask for the warranty to be extended. Also thinking of emailing GM on this. Any thoughts or recommendations

more info
2017 cruze purchased June 2017
1st occurred 1.19.18 @3,298
2nd time 5.23.18 @ 5,533
3rd time 1.19.19 @ 9,400
 

·
Administrator, Resident Tater Salad
Joined
·
16,734 Posts
welp just had this occur again third time. The funny thing this happend for the first time today. Now that this has happened 3 times now it has me worried and with only 1 year left on bumper to bumper warranty. Since I think this would only be fixed free under bumper to bumper. Ill contact the dealer tomorrow to get this fixed. Almost wondering if I can ask for the warranty to be extended. Also thinking of emailing GM on this. Any thoughts or recommendations

more info
2017 cruze purchased June 2017
1st occurred 1.19.18 @3,298
2nd time 5.23.18 @ 5,533
3rd time 1.19.19 @ 9,400
Ask them to check for an air leak. This shouldn't keep happening.

Sent from my SM-G950U using Tapatalk
 

·
Registered
Joined
·
42 Posts
Discussion Starter #7
Thank You. I will mention that and probably get the service advisor a headache saying figure out why that part keeps failing and have the car looked at closer and for them to replace the parking brake pedal since it has a crack in it. I see othere have had that problem and remember reading 1 person got push back. Lets just hope they do not take a bite out of my bumper like last time they fixed it and promised id not be back.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #8
another dumb thing and it is probably normal. been noticing recently the oil life % has been dropping faster over the last 2 months when comparing previous months. I was chalking it up to the colder winter weather, any possible correlation?
 

·
Administrator, Resident Tater Salad
Joined
·
16,734 Posts
another dumb thing and it is probably normal. been noticing recently the oil life % has been dropping faster over the last 2 months when comparing previous months. I was chalking it up to the colder winter weather, any possible correlation?
Haven't noticed with mine but it's been on the road a LOT lately. Short trips drive down the oil % more quickly since it gets less of a chance to warm up and boil off water. Fuel dilution is higher on cold starts as well.

Is there another dealer in town you can go to?

Sent from my SM-G950U using Tapatalk
 

·
Registered
Joined
·
42 Posts
Discussion Starter #10
ah yeah been doing a little more short trips lately when its cold. Work is only about 12 miles away non highway. But ive been stopping over lately to my moms to help her out and its like a 3 minute 2 mile ride away. I normally let the car warm up for a minute before taking off when its cold and then drive very slow and keep under 2k for a bit Yes there are 2 other Chevy dealers in the area and a combo chevy/Toyota one near work. I just called my dealer and told them ill be in at 7am and want a loaner waiting. Will see if gets fixed this time otherwise new dealership. Thank You
 

·
Registered
Joined
·
42 Posts
Discussion Starter #11
At the dealer bright and early. layed into my service advisor about the problem. Also guess he is the only one in and like did you schedule a loaner since I dont have one ready. So it will be about 20 minutes. Guess I should have been a jerk when I called yesterday
 

·
Registered
Joined
·
42 Posts
Discussion Starter #12
Evening so no real update. Car still shows untouched in the status. Also no contact from the dealer. Service advisor said probably will not get it back till next week when he got me setup on my loaner Malibu. No word back from GM about my email about my concern. I'll have to call them up to chat.
 

·
Super Moderator
2014 LT program car, Pull Me Over Red
Joined
·
8,442 Posts
Potential causes for this code to set are:


Defective O2 sensor(s)
Burnt, broken, or disconnected wiring and/or connectors
Defective catalytic converter
Engine exhaust leaks


Read more at: https://www.obd-codes.com/p015b



Have you noticed if the oil level is changing? I only ask as that is a possible reason for the Cat to go bad, assuming it leaks into the exhaust possibly via the turbo.


Just wondering aloud....

In the mean time - burn up miles on their car!
 

·
Registered
Joined
·
42 Posts
Discussion Starter #14 (Edited)
haha I did rack up some miles on it this weekend. I haven't really noticed the oil level. I have checked it a few times and seemed fine. I did just get a voicemail from the dealer a few minutes ago. Car is ready and it was not a O2 sensor this time but an engine control modules reprogramming issue. I'll have to look into what that means exactly later.
 

·
Registered
Joined
·
922 Posts
Document # is for a service procedure to update the ECM programming on a certain population of 1.4T/auto 2017 Cruzes due to an oversensitivity to setting P015B.

The program code is the verification code that the Tis2Web programming creates following a calibration event. It's how GM keeps track of and verifies proper programming procedures are being performed under warranty. The number has no useful meaning to anyone outside of GMs warranty payment people, and data keeping track of when the car was programmed.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #18 (Edited)
So Chevy got back to me yesterday on my email over to them about me crying about the check engine light coming on 3 times within about 1.5 years of ownership. They told me they would be giving me a GM platinum protection plan with zero deductible with 5 years or 60K miles on top of my current miles I already have. Said I would be getting a card and more details in the mail. The funny thing is they said this was a follow up call and that my dealer should have contacted me and I was like nope dealer never reached out to me on this. They did say that not all dealers honor the protection plan but the dealer I have used does. I have to read up on the GM Platinum protection plan, hopefully it is not junk and if I run into a problem it will take care of me. Hopefully I do not see another check engine light on in the next this year, otherwise I will be crying :RantExplode: again.

Thank You for all the feedback and information
 

·
Registered
Joined
·
42 Posts
Discussion Starter #19
haha check engine light came on the morning ride to work. I called up a different dealership to and have an appt for tomorrow morning. Also will be contacting GM
 

·
Registered
Joined
·
42 Posts
Discussion Starter #20
Dropped off my Cruze this morning to the different dealer service advisor told me its a known issue and GM has changed how this gets fixed recently. Other dealer didn't tell me anything. They are out of loaners but drove me to work and said theyd call me in about an hour if they can not fix today and that some loaners should be back
 
1 - 20 of 38 Posts
Top