Chevrolet Cruze Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 · (Edited)
About a week ago the Check Engine Light came on my 2014 Cruze Diesel. I bought a reader but it doesn't display an actual code and I'm confused how to read this. I read some where that Chevy makes so end users can't find the codes and they can only be read by their machines.

I've cleared the code twice and each time it's eventually returned. Strange enough the first time it appeared occurred after a remote start.

Dealership stated they'd do a diagnostic but if the code is about emissions I must pay $110 unless it's about the Power Train which the warranty still covers. My car has 59,7000 miles on it. FYI I've double triple checked for a lose gas cap.

Any help would greatly be appreciated. Thanks
 

Attachments

·
Premium Member
2014 Cruze Diesel, 2007 Cobalt, 1981 Camaro Z28, 2017 Volt
Joined
·
5,671 Posts
We got that same thing on ours a couple weeks ago. No noticeable change in how the vehicle drove, and my code reader wouldn't give me a code. I cleared it, and it hasn't been back since.
 

·
Registered
Joined
·
24 Posts
I would try a different scanner. The ECU for the Cruzes use the CANSF protocol I'm pretty sure. Your scanner says CAN on it. I'm not familiar with the different types of scanners but I've used an autozone scanner on my car before and it pulled codes. Go to a parts store and see if they can pull the code.
 

·
Reverend Red Bull
Joined
·
1,095 Posts
My $15 Bluetooth OBD scanner I got off Ebay from China has been able to get me the code using Torque Pro for Android for all of my engine lights on my Diesel. Since my very cheap, very generic scanner works, I'd guess that the difficulty is particular to the interaction between this scanner and this ECU rather than being a broader GM problem.
 

·
Premium Member
Joined
·
8,003 Posts
A number of people have been able to pull codes using borrowed part store scanners. So, I'm inclined to side with a scanner issue than anything GM is doing.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #8 ·
This got worse quick. I ended up receiving a "Service Exhaust Fluid System" which began restricting my max speed. Dealership told me it's a dead DEF heater and that it would be covered under warranty despite I'm at 65,000 miles. #Phew
 
1 - 8 of 8 Posts
Top