Chevrolet Cruze Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 · (Edited)
Yeah I've got a 2015 Cruze 101 thousand miles an I purchased goin on 2 months ago an ever since it has had alot of problems second day sprays oil an then i fix that then somethin else goes wrong blah blah so stressful the GM dealership I got it from helped then stopped. Anyway this car had cooliant HOLES REPLACED, cover gasket, gasket oil CAP seal, A oil sensor an OTHER stuff replaced . Then a emissions engine light came on so I scanned it with my buddy's tool and it through emissions code as well through *Onstar LiVe diagnostic test came up as Emissions so I DELETE codes so 3 weeks went by an ENGINE LIGHt POP BACK ON for that problem (Emissions )So I bring to my closes Gm not the dealer ship I got car from so anyway they diagnose it a Bad catlytic convertor an gonna cost me 1000 plus.. i feel that's not the problem. What would yall think... they charged me over 300 to do test warranty SUCKS dont cover an CREDIT place worthless an dealer ship i got from wont help so what do I do


If I had deleted code an took 3 weeks to come back an didnt come right back makes me thing it isnt as bad as a CATLytic convertor

But they said not any filters or 02 sensor thats bad just CATLytic convertor..




apologies ive been stressed ever since I've got this car an just now paying 2nd payment .
What can I do ..
 

·
Super Moderator
2015 Chevrolet Cruze LT 1.4L Turbo
Joined
·
3,236 Posts
Yeah I've got a cruze 2015 very clean inside out goin on 2 months ago an second day sprays oil an then fix then somethin else then again blahs blahs the GM dealership helped then stopped anyway this car had cooliant cover gasket gasket oil lid seal oil sensor an stuff replaced an emissions engine light came on so I scanned it with my buddy's tool and it through emissions code as well through onstar diagnostic line test was emissions.so I DELETE codes so 3 weeks went by an ENGINE LIGHt POP BACK ON.So I bring to my closer Gm an they diagnostic it bad head gasket an gonna cost me 1000 plus.. i feel that's not the problem. What would yall think they charged me over 300 to do test warrant SUCKS ass an CREDIT place worthless an dealer ship so what do I do
Please punctuate your post. I'm trying to read it and I can't make sense of it; Other than the fact your angry and you don't trust the dealership's diagnosis.

After you edit your post so we can make sense of it, please post the trouble codes that you have?

Also, how did the dealership conclude that you needed a head gasket? Did they do a block test?

Thanks
 
  • Like
Reactions: NHIA

·
Registered
Joined
·
19 Posts
Discussion Starter · #3 ·
Apologies thanks for the help first time gettin car fianced an feel like been screwed
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #5 ·
Please punctuate your post. I'm trying to read it and I can't make sense of it; Other than the fact your angry and you don't trust the dealership's diagnosis.

After you edit your post so we can make sense of it, please post the trouble codes that you have?

Also, how did the dealership conclude that you needed a head gasket? Did they do a block test?

Thanks
I corrected some an posted pictures
 

·
Registered
Joined
·
42 Posts
P0420 means the readings between the front(upstream) & rear(downstream) O2 sensors aren't where they should be. Yes it could be a faulty catalytic convertor, but could also be one of the two 02 sensors is bad or wiring to them bad. Since you said the light was off for three weeks, I'm willing to bet it's not the convertor. If it was my car, I would replace the rear O2 sensor which is the downstream sensor. DO NOT buy a cheap O2 sensor. Spend the $$ on Bosch or ACDelco. AcDelco 213-4698 is $25 on amazon. If you've never done one before, spray the sensor a couple times a day for a day or two while you are waiting on the part to arrive. You may have to buy or rent a O2 sensor socket. I have them, and can't remember if I needed to use them when I did them on my daughter's 2013.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #7 ·
Thanks I may try this bc CATLytic convertor very expensive now just in trying to find the correct 02 sensor an toy I'm not much of mechanic but I'll see about it it looks way better price that CATLytic c .
 

·
Registered
Joined
·
2 Posts
I have P0299 and P0420 I just changed both O2 sensors my old man thinks I need to change my catalytic converter! Any tips or ideas before spending money on that repaid has 87k miles 2014 Cruze lt
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #10 ·
P0420 means the readings between the front(upstream) & rear(downstream) O2 sensors aren't where they should be. Yes it could be a faulty catalytic convertor, but could also be one of the two 02 sensors is bad or wiring to them bad. Since you said the light was off for three weeks, I'm willing to bet it's not the convertor. If it was my car, I would replace the rear O2 sensor which is the downstream sensor. DO NOT buy a cheap O2 sensor. Spend the $$ on Bosch or ACDelco. AcDelco 213-4698 is $25 on amazon. If you've never done one before, spray the sensor a couple times a day for a day or two while you are waiting on the part to arrive. You may have to buy or rent a O2 sensor socket. I have them, and can't remember if I needed to use them when I did them on my daughter's 2013.
See post thanks imma try
 
1 - 10 of 10 Posts
Top