Chevrolet Cruze Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello,




About a month ago our check engine light came on, followed by a Service ESP and Service Traction Control warning signs on our dashboard. It wasn't too long after that we heard this hissing high pitched sound coming from the engine. We took it to Tire Kingdom and a good friend mechanic of mine helped me out and what he thought would fix the issue did not.


About 2 weeks ago, we took our Chevy Cruze 2011 LS to a nearby Chevy dealership here in Tampa. They ran a series of diagnostics and found many codes and we were advised that the negative cable needed to be changed because it is causing the codes, and the computer needed to be re-programmed. I asked the service person over there to confirm if the hissing high pitched sound would go away, along with the service ESP and traction control warnings and they said, it might go away. We proceeded with the repair, unfortunately the issue is still there, the sound, the once in a while slight jerking of the car during idle, and the warning lights on the dashboard. After paying and before leaving, they said they suspect it could be a vacuum leak and the valve cover needed to be replaced.


At that point I didn't believe these guys anymore, I felt like they took advantage of me instead of telling me in the first place what was wrong with the car, but instead they insisted that the negative cable needed to be replaced. Now I am at a point where the sound coming from the engine is unbearable and I want it fix. After hours of research online and listening to my car, and looking over the diagnostic reports which included in there that there's a vacuum leak and they wrote down on the report that the valve cover needed to be replaced.

Does anyone have any ideas? Anything is much appreciated.
 
1 - 2 of 2 Posts
Top