Chevrolet Cruze Forums banner

1 - 20 of 30 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hey guys, so I had my car diagnosed for a chirping noise. Basically, the mechanic told me it was the valve cover gasket that needed to be replaced and oviously gave me an outrageous price to fix it. I went ahead and ordered the part directly from GM and replaced ity self but the chirping noise is still there. So now I don't know what it is that is causing it. if anyone had this problem before, I can really use some help .
 

·
Registered
Joined
·
1 Posts
Hi I have the same issue... I took it in for a repair for the chirping noise and they said it was a worn belt.. ok.. Told them to replace the belt AT THE COST OF $200.00. ... Picked up the car and drove to the store... HAHAHAH. Still There. Took it back and the head machanic came out and pulled out my dip stick and the chirping was gone!!!!! He told me it was do to a faulty design in the rear main seal of the oil pan and the chirping was caused by air bEing sucked into to motor.. WOW I said.. Then he told me not to worry.. HAHAHAHAHAH. I said really.. Ok This was in front of the service writer as well. Neither one offered to give me a refund for the belt I DID NOT NEED.. So I and never going back to Silver Star Chevy in Thousand Oaks.. I am shopping at Mercedes Benz... I also told the manager and he did NOTHING!!!!! I AM DONE WITH CHEVY AND ALL THE LIES.. GOOD LUCK CRUZE OWNERS....
 

·
Premium Member
Joined
·
865 Posts
Hi I have the same issue... I took it in for a repair for the chirping noise and they said it was a worn belt.. ok.. Told them to replace the belt AT THE COST OF $200.00. ... Picked up the car and drove to the store... HAHAHAH. Still There. Took it back and the head machanic came out and pulled out my dip stick and the chirping was gone!!!!! He told me it was do to a faulty design in the rear main seal of the oil pan and the chirping was caused by air bEing sucked into to motor.. WOW I said.. Then he told me not to worry.. HAHAHAHAHAH. I said really.. Ok This was in front of the service writer as well. Neither one offered to give me a refund for the belt I DID NOT NEED.. So I and never going back to Silver Star Chevy in Thousand Oaks.. I am shopping at Mercedes Benz... I also told the manager and he did NOTHING!!!!! I AM DONE WITH CHEVY AND ALL THE LIES.. GOOD LUCK CRUZE OWNERS....
Well then, good luck with your "breakdown free" Benz ... LOL I highly encourage you to peruse the MB forums out there, as well as look at other sources of information about repair costs (as well as unexpected breakdowns), and "least reliable cars" lists, because Mercedes and BMW are on each and every one of them that I've seen. I've also talked with many owners personally, and each of them has talked about expensive repairs unexpectedly, on the average of about once per year. I can't speak for you, but if I KNEW I were thinking about purchasing a car that has a known breakdown regularity, I'd be looking elsewhere for sure, especially at the price you pay for the MB nameplate. You'll have to keep us informed about your new purchase and the first time it breaks down, let us know the cost and time the dealer has the car to repair it ...
 

·
Super Moderator
2014 LT program car, Pull Me Over Red
Joined
·
8,845 Posts
Hi I have the same issue... I took it in for a repair for the chirping noise and they said it was a worn belt.. ok.. Told them to replace the belt AT THE COST OF $200.00. ... Picked up the car and drove to the store... HAHAHAH. Still There. Took it back and the head machanic came out and pulled out my dip stick and the chirping was gone!!!!! He told me it was do to a faulty design in the rear main seal of the oil pan and the chirping was caused by air bEing sucked into to motor.. WOW I said.. Then he told me not to worry.. HAHAHAHAHAH. I said really.. Ok This was in front of the service writer as well. Neither one offered to give me a refund for the belt I DID NOT NEED.. So I and never going back to Silver Star Chevy in Thousand Oaks.. I am shopping at Mercedes Benz... I also told the manager and he did NOTHING!!!!! I AM DONE WITH CHEVY AND ALL THE LIES.. GOOD LUCK CRUZE OWNERS....

Now that you have gotten that off of your chest and yelled at the very group who may have been able to help you...good luck at Mercedes.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
UPDATE * I had the problem narrowed down to the water pump after breaking the thing apart and I had it checked out by another shop just to be sure. Lucky for me the water pump is covered by the 5 year Chevy warranty so I'm waiting ont the dealer to set a date to get my car fixed. I'll post another update if having the water pump replaced fixes the problem. Thank you guys for the input
 

·
Super Moderator
Joined
·
5,535 Posts
Chirping...check for a loose plug(s).

Steady squeal at idle...remove dipstick while engine is running......noise gone...likely front (belt side) crank seal.
Noise still there.....water pump or other belt driven component.....loose belt tensioner, lift belt off any pully so it hangs free from the crankshaft pulley and start engine.....noise gone? water pump or alternator or a/c pulley bearing or tensioner.....anything the belt turns is suspect once the crank seal has been ruled out.

Rob
 

·
Registered
Joined
·
38 Posts
Cant just replace the gasket. Must replace cover and gasket. Might need new oil dipstick too. Known problem on the gen 1. That's why it cost so much to repair.
 

·
Registered
Joined
·
1 Posts
I had the same issue, along with a very rough idle. Valve gasket was the culprit, luckily I am still under an extended warranty and this was covered. There was also a stuck valve, which resulted in another trip for repair. This time out of pocket was $100 deductible, but majority covered under warranty. Good luck.
 

·
Registered
Joined
·
2 Posts
The chirping is coming from spring in spark plug boot not aligned with spark plug . Remove coil pack and check all your spark plug boots that springs are aligned correctly
 

·
Registered
Joined
·
439 Posts
I agree with Robby. My bet is on crank seal. Its a very common issue on Cruzes. Mine went bad around 25k. It sounds like a mouse squeaking.
 

·
Registered
Joined
·
2 Posts
Hi I have the same issue... I took it in for a repair for the chirping noise and they said it was a worn belt.. ok.. Told them to replace the belt AT THE COST OF $200.00. ... Picked up the car and drove to the store... HAHAHAH. Still There. Took it back and the head machanic came out and pulled out my dip stick and the chirping was gone!!!!! He told me it was do to a faulty design in the rear main seal of the oil pan and the chirping was caused by air bEing sucked into to motor.. WOW I said.. Then he told me not to worry.. HAHAHAHAHAH. I said really.. Ok This was in front of the service writer as well. Neither one offered to give me a refund for the belt I DID NOT NEED.. So I and never going back to Silver Star Chevy in Thousand Oaks.. I am shopping at Mercedes Benz... I also told the manager and he did NOTHING!!!!! I AM DONE WITH CHEVY AND ALL THE LIES.. GOOD LUCK CRUZE OWNERS....



Maybe a dumb question but did the head mechanic say there was anything to do about the faulty design?
 

·
Registered
Joined
·
1 Posts
I have same problem. Chirping noise at idle, been going on for 6-8 mos, it stops when I take out the dipstick, I was told the valve cover needs replacing and the seal. Not sure if this solves the faulty design issue and I've learned the noise will come back even after replacing these 2 at the tune of $500.
 

·
Premium Member
2013 Cruze 1LT
Joined
·
989 Posts
I have same problem. Chirping noise at idle, been going on for 6-8 mos, it stops when I take out the dipstick, I was told the valve cover needs replacing and the seal. Not sure if this solves the faulty design issue and I've learned the noise will come back even after replacing these 2 at the tune of $500.
No, what fixes it is getting one of these before replacing them: https://cruzekits.com/about-pcv-fix-kits
 

·
Super Moderator
2014 LT program car, Pull Me Over Red
Joined
·
8,845 Posts
I recently had the valve cover replaced and thought all was well, but noooo, I just had the tensioner, the belt and the crank seal replaced. I just need to install the kit I have on the spare intake I also have and cross my fingers now.
 
1 - 20 of 30 Posts
Top