Chevrolet Cruze Forums banner

Chevy Cruze 2.0 diesel, 2015 model

699 Views 2 Replies 3 Participants Last post by  Rivergoer
Hi,
I own a Chevrolet Cruze 2.0 diesel, 2015 model and its been giving me **** since I bought it. I live in Ghana, West Africa and I had my cruze from an auction in North America .i.e., Canada in July 2017.

I have this persistent issue with the DIC saying "Exhuast Fluid quality poor". The fluid has been changed, exhaust system cleaned and still not working; meanwhile my speed limit is now 8km/hr.
Can someone assist me as to what could be causing this problem?
1 - 3 of 3 Posts

· Registered
Joined
·
26 Posts
You should probably get the codes if there is a check engine light. And it must have been an ongoing issue if your speed has already been reduced to 8km/hr. There are steps to the speed reduction. Did you not get any warnings before?
 

· Premium Member
Joined
·
2,608 Posts
Hi,
I own a Chevrolet Cruze 2.0 diesel, 2015 model and its been giving me **** since I bought it. I live in Ghana, West Africa and I had my cruze from an auction in North America .i.e., Canada in July 2017.

I have this persistent issue with the DIC saying "Exhuast Fluid quality poor". The fluid has been changed, exhaust system cleaned and still not working; meanwhile my speed limit is now 8km/hr.
Can someone assist me as to what could be causing this problem?
Welcome to the forum, sorry you’re having trouble with your Gen 1 CTD. A couple of things to check/consider would be the Negative Battery Cable and/or possible DEF Tank Heater failure. Both are known issues and have extended special coverage provided by GM.

http://www.cruzetalk.com/forum/25-g...al-coverage-14311-negative-battery-cable.html

http://www.cruzetalk.com/forum/64-g...ent-diesel-emission-fluid-tank-reservoir.html
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top