Chevrolet Cruze Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 · (Edited)
Hey Guys,


I'm having issues with my 2011 chevy cruze 1LT 1.4 turbo. Anytime I give it gas the engine start to chirp. It seems like it's coming from the PCV valve. It also gets worse or is constantly on when the A/C is on and I'm just idling. Can anyone confirm the sound and if it is in fact the pcv valve?




Thanks!
-Dan
 

·
Administrator
Joined
·
25,596 Posts
Possible, but it could also be a loose spark plug. The plugs in our engine chatter and chirp when not properly torqued.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Thanks obermd. It's definitely coming from the valve cover. I'm trying to post a video of it, but the site isn't allowing me to unless I post "3 posts" since I'm new to the forum. Once I get the 3rd post i'll link the video from youtube.
 

·
Administrator
Joined
·
25,596 Posts
Spark plugs are directly under the valve cover.
 

·
Administrator
Joined
·
25,596 Posts
Definitely check your spark plug torque. That's exactly what my ECO sounds like if I don't get the plugs tight enough.
 

·
Premium Member
Joined
·
1,226 Posts
If this was my car, I would check the torque on the spark plugs first because its easy and it would suck to have a spark plug blow out the top and destroy the threads. There are many threads about changing spark plugs. Read one before you do it. Torque is 25nm or 18lbft. Be careful with the boots because they can tear. And check the springs before you put the coil pack back on to make sure they are not stuck in the boot. I always coat the boots with dielectric grease to make it easier to remove next time.

But, this might also be the PCV. There are a lot of threads on the forum about that as well. I believe there was a test where you could lift the dipstick to see if it goes away, but you might want to do a search and read some of those threads first.
 
1 - 7 of 7 Posts
Top