Chevrolet Cruze Forums banner
1 - 14 of 14 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter · #1 ·
Yesterday the climate controls stopped functioning completely. When I hit buttons the radio display responded correctly, however nothing happened, not changing vents, no temp change, nothing, wouldn't even turn off. It wasn't locked up cause the radio display showed the buttons correctly as I hit them. It was blowing hot air out the front vents no matter what button I pressed (floor, defrost etc) and it blew hot air regardless of the temperature knob position. I even turned it clear to cold and turned on A/C and it seemed to blow hotter. I checked the engine temps and it was normal, no check engine lights or anything. I wouldn't even turn off. I had to shut the vents and ride with the windows down. I called and made an appt for today with the dealer.

Well I got up this morning to take my wife to work, and boom, everything is working great. No issues at all. All functions are working again. Air is cold when turned to cold and hot when turned to hot. I have a state inspection due next month so I cancelled the appt and will have them check everything out then since it seems to be normal. All day today it has been fine. I am so confused and upset. My bumper to bumper warranty is up in 16,000 miles and it wants to start this crap. Since its back to normal the dealer can't do anything other than tell me "we couldn't find anything wrong" when I take it next month. This car is starting to make me miss my Aveo. That car was a enonomy crap box but never was in for warranty work in the whole 108K miles I owned it.
 

·
Registered
Joined
·
389 Posts
Just like your home computer, just have to reboot sometimes.
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #3 ·
Just like your home computer, just have to reboot sometimes.
I sure hope thats all it is. Like I said, 16K left on the ol warranty, this stuff gets me really worried. With the aveo being the exception, I usually have close to 250K on a vehicle when I get rid of them, need this one to do the same.
 

·
Registered
Joined
·
389 Posts
Mine did the same thing. I just turned the car off and restarted after about 15 seconds and everything was fine.
 

·
Premium Member
Joined
·
3,975 Posts
I assume yours is a '11 model. Have you ever had the dealer do a software update on it for any reason? Fortunately, the Cruze doesn't experience the Blue Screen Of Death like Windows used to do so frequently.
 

·
Registered
Joined
·
682 Posts
Mine did the same. Require a battery disconnect for about 30 min to reset the system. Take it to the dealer though. There is a program update for the hvac system that it might need. Mine did.
 

·
Registered
Joined
·
18 Posts
Same exact thing happened to me a couple of months ago. Mine would not clear if shutdown and restarted, it required a battery disconnect to reset. I'm stacking all warranty issues (potential reprogram for this issue) and recall(s) and will get them all done in a single shot once a more critical issue manifests itself or I near the end of my 3yr/36K.
 

·
Premium Member
Joined
·
5,002 Posts
Will this also fix hot air coming out of vents when heater is off and circulate is on?
 

·
Registered
Joined
·
143 Posts
I had the same problem, although instead of disconnecting the battery, I pulled the under dash fuse (marked AC), and put it back in after about 15 seconds. Eventually, I will bring it in for the software update.
 

·
Registered
Joined
·
682 Posts
Will this also fix hot air coming out of vents when heater is off and circulate is on?
It should yes. Mine was EXACTLY the same as OPs. Hot air and everything. It was brutal trying to drive around because if the air was off the windows would fog up. And if it was on it was as hot as ****. Battery pull and software update fixed all.
 

·
Premium Member
Joined
·
5,002 Posts
Thanks, so dealer is the only way to upgrade software right?
 

·
Super Moderator
Joined
·
5,151 Posts
Mine did the same thing last Saturday and they Sunday no more problem. Except mine all the air came out my dash vents. Gremlin in the heat ducts? I am still reluctant to take my car back to the dealer for the software upgrade since they will say bring it in Mon.- Fri. and their hours are inconvenient!
 

·
Registered
Joined
·
1 Posts
My Auto climate control blows cold air when outside temperature is 20 F and inside temp is 55 F and auto temp is set to 86 F. This occurs on bright sunny days, but works ok at night. After three months, dealer can not fix problem. Factory "fix" is to cover the solar sensor on the dash. This "fix" works but car then displays all exterior lights and interior dispays are dimmed to the point of not being visible.

Apparently a software problem which factory is unable to properly repair.
 
1 - 14 of 14 Posts
Top