Chevrolet Cruze Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
159 Posts
Discussion Starter · #1 ·
My 2012 Eco 6m just rolled 180K miles. A day after bragging what a great, problem-free car it's been the temperature knob has quit changing the temperature. It doesn't matter where I set it, or if the A/C is on or not, it blows hot air. I haven't seen any other posts about this issue, does anybody have any experience with this issue? Switch maybe? TIA
 

·
Premium Member
Joined
·
733 Posts
My 2012 Eco 6m just rolled 180K miles. A day after bragging what a great, problem-free car it's been the temperature knob has quit changing the temperature. It doesn't matter where I set it, or if the A/C is on or not, it blows hot air. I haven't seen any other posts about this issue, does anybody have any experience with this issue? Switch maybe? TIA
When you adjust the knob, there's a motorised flap that moves to control how much hot and cool air is pushed through the vents into the car. My guess is the flaps are stuck and are no longer moving. Something may be physically blocking them or the motorised mechanism may have simply failed.
 

·
Premium Member
Joined
·
8,003 Posts
I'm not sure if it's those doors, but a few have found the gear broken and lying on the floor.

One thing you can try - disconnect the battery for a few minutes. Be sure the driver's door is closed when you reconnect.

When you start the car again, wait about a minute before changing anything on the climate control.
 
1 - 3 of 3 Posts
Top