Chevrolet Cruze Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Mystery leak: I recently replaced the turbo oil feed line on 2011 80k+ 2lt rs package Cruze. Oil has stopped seeping from that line but the noxious smell of burning oil remains at idle and intensifies with the heat on. Oil is clearly leaking into or onto the exhaust but from where I'm not sure. Under the hood there's a faint amount of smoke coming from the area around the heat shield infront of the turbo but theres no visible oil pooling up from looking down into the engine.Yesteday I went to the shop only to be told I need to visit a dealership to have it fixed. They told me the underside looking up from underneath the engine is soaked in oil. The shop said it's the turbo but there's no code coming up on the scanner and I haven't lost power or had any other symptoms of a failed turbo despite having to replace the oil feed line. In addition I've performed Oil changes as scheduled by the GM specifications for this car. The shop also mentioned a leak coming from the valve cover was noticeable. Seeing as how the PCV is part of that assembly I'm hoping to repair it myself with a clear diagnosis made from someone in this community. I've repaired other issues with this car using this forum and have not been able to find a case that exactly matches mine this time. If you know what this issue is please don't hesitate to respond to this post. Thank you for taking the time to look at the poor form me and the car I'm trying to keep alive are in.
 
1 - 2 of 2 Posts
Top