Chevrolet Cruze Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 · (Edited)
After pcv mod, 2014 cruze 1.4 ran great. Later that day couldnt go faster than 5mph, car shakes, Stabilitrak light came on, codes p0299 and now cylinder 4 misfire. Please help with anything u guys got. Oh and the fan kicks on every time i pull the key out, no matter how cold the engine is.
 

·
Registered
Joined
·
5 Posts
Speed Decrease: The P0299 code indicates that the Turbo or Supercharger "A" has excessively low output. The ECU looks for a specific range of boost and when the low boost is detected by the ECU, it sets a P0299 code. This code will illuminate a Check Engine Light on the dashboard and may put the vehicle in limp mode. This would explain the 5 mph speed limit. Which PCV fix are you referring to is it one of the Gen 1 Engine/Trans tutorials?
 

·
Registered
Joined
·
5 Posts
I was reviewing your posts from the PCV fix. The code you listed is for Turbo Underboost. I would check what Extream suggested which is have a compression test done on your cylinders and take a peak at the Check Valve at the Turbo Inlet. Depending on how long it was before you noticed the Valve Cover Rupture could have caused damage to the engine or turbo. As for the fan, This is just a shot in the dark honestly I have seen a lot of cars due this but not when the engine is cold. There could be a damaged temperature sensor or loose plug somewhere just poke around and see if anything looks out of place. If nothing looks out of place maybe replace the temperature sensor. Now if the fan runs after the key is out and does not stop and stays running you might have a bad ground somewhere.

Good Luck, Hope you get her fixed up and running let me know how things turn out.
 
1 - 4 of 4 Posts
Top