Chevrolet Cruze Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hi guys,

Need some advice again please!

I had driven 300 miles yesterday when the engine started misfiring and the engine warning light came on. I pulled over shortly after and got recovery guy out. He read the codes and they said that it was misfiring on cylinder 2. He said I needed a new coil pack but only had spark plugs so changed them for me.
So, car now is not misfiring. I have driven 500 miles since but I still have an issue. Which is that acceleration can be intermittent ( only when revs are low). The engine jerks a little - but not as much as a misfire I think. No warning lights come on. Could these be down to coil pack or ht leads. I thought coil pack would fail completely not partially.

Thanks in advance for your help.

Cheers
 

·
Moderator
Joined
·
2,170 Posts
Hello! How many miles are on the car? Has it ever had the spark plugs replaced before?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Thanks for reply, It has 45000 on clock. I think it had plugs replaced when I had full service 12 months ago. In that time I have done 8-10000 miles.
 

·
Premium Member
Joined
·
376 Posts
According to Google search results they can partially fail.
Have you rung a few mechanics and asked them the same set of questions? Don't tell them what you believe to be the cause of the problem - only the symptoms - and see if several professionals come to the same conclusion.
 
1 - 4 of 4 Posts
Top