Chevrolet Cruze Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi all,

My 2010 holden cruze diesel automatic randomly dies while driving.

I still have electronics when it dies because all the warning lights come on. And after it dies it wont start for up to 30 mins.

I have taken it to a few mechanics and they've replaced the battery the fuel pump and filter and run diagnostic test with no faults showing.

Has anyone had this issue, could you tell me what it was because i have been told to replace the transmission and the ecu.

Cheers Luke
 

·
Premium Member
Joined
·
8,003 Posts
One member with a gasser found a problem with the "ignition" relay. While diesels don't have ignitions, I'm sure they do have a relay that runs the electronics that runs the fuel injectors. It's probably a $10 part. Probably worth swapping for a heck of it.

You might also check the voltage between the battery ground cable's ground and the battery post itself. Here in the US, we've had a problem with that cable. If you see more than 0.1 volt while running, replace it.
 
  • Like
Reactions: spacedout

·
Registered
Joined
·
948 Posts
You say you've taken it to a few macs - have you taken it to a Holden Dealership to have a really good look at it?

That's because most of the information about the Cruze costs $$$'s to access, unless they are doing a lot of Cruzen I can't see a local mac spending it.

If you are in Melbourne I can recommend Brighton Holden on the highway in Elsternwick (where Reg Hunt's used to be). They haven't burnt me, yet.
 

·
Premium Member
Joined
·
4,652 Posts
  • Like
Reactions: obermd

·
Premium Member
Joined
·
4,652 Posts
  • Like
Reactions: obermd
1 - 6 of 6 Posts
Top