Chevrolet Cruze Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Cruze LT 2015, 95 k kms driven, ATF change was done at 65 k. For the last last few months, the drive has been crappy. Acceleration is poor, to the point that overtaking seems almost impossible at times. There is a vibration at speeds over 70/ 80kmh and the rpms fluctuate between 1500 and 20/2500 while decelarating. Worth mentioning here is that the speed doesnt fluctuate, its just the RPMs jumping with vibration with each jump. On rare occasions, it would drive perfectly for a single drive cycle but thats very very rare.
I suspect its the transmission or the torque converter though the gear shift seems fine.

Another point i'd like to mention, though not sure it relates to the problem is that i can hear the fuel pump prime only once in around 50 starts but the car starts fine.

Any ideas as to what might be the culprit?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I had the same kind of issue. I fixed mine by replacing the spark plugs and properly gapping them.
Thanks. I was told the same thing by a friend yesterday. He had to change the coilpack and the plugs on his cruze 2018 to get rid of this issue. So i'll start with plugs first and then the coilpack maybe,if needed. What's the reccomended gap anyways? Can i gap them myself considering i'll get the regular ac delco sparkplugs?
 

·
Registered
Joined
·
32 Posts
Thanks. I was told the same thing by a friend yesterday. He had to change the coilpack and the plugs on his cruze 2018 to get rid of this issue. So i'll start with plugs first and then the coilpack maybe,if needed. What's the reccomended gap anyways? Can i gap them myself considering i'll get the regular ac delco sparkplugs?
Yeah you should be able to. Recommended gap on the stock tune is 0.28
 
1 - 4 of 4 Posts
Top