Chevrolet Cruze Forums banner

Did timing belt, starts and runs, but issues...

3782 Views 23 Replies 10 Participants Last post by  LulzT1
I have a 2014 diesel cruze with 106,000 miles. I replaced the timing belt and water pump.

When it was put back together it fired right up without a problem, sounded perfect... However, the Stabili trak and TCS needs service lit up, as well as the check engine light. The tachometer also does not work, as well as when it is put into gear it the transmission shifts very harshly and once underway the automatic transmission does not shift out of second.

Does anyone have any thoughts on what I messed up? And also how to fix it?

Also, I hooked the car up to my code reader, and got the P0016 code. As I said, it starts and runs just fine.
1 - 3 of 3 Posts

· Registered
2014 Cruze TD
Joined
·
1,057 Posts
I don't know if the HPFP pulley actually cares, but it's the spacing between the fuel pump park and the cam mark that is important, which is the reason the mark is there. Would you agree? When I did my belt I made sure the fuel pump mark lined up so that the spacing on the teeth would still be correct so whether it was needed or not, it was done.
I have a 2014 diesel cruze with 106,000 miles. I replaced the timing belt and water pump.

When it was put back together it fired right up without a problem, sounded perfect... However, the Stabili trak and TCS needs service lit up, as well as the check engine light. The tachometer also does not work, as well as when it is put into gear it the transmission shifts very harshly and once underway the automatic transmission does not shift out of second.

Does anyone have any thoughts on what I messed up? And also how to fix it?

Also, I hooked the car up to my code reader, and got the P0016 code. As I said, it starts and runs just fine.
Did you pull the the wheel liner out to get access to the crank pully? It sounds like maybe you damaged or unhooked the wheel speed sensor. That may explain the first two errors. I'm not sure if that would affect shifting though.
 

· Registered
2014 Cruze TD
Joined
·
1,057 Posts
there is no timing on a hpfp.. it just sends pressure... Just like any other fuel pump just way higher. The car uses the cam and crank to decide when to fire the injector. My belt never matched up on the hpfp.. no problems... The only problem I had was the seal leaked on the hpfp.. so If anybody is doing a timing belt I would change the hpfp shaft seal at the same time.. easy job. saves lots of time if you don't have to do the belt twice.
How do you change it?
 

· Registered
2014 Cruze TD
Joined
·
1,057 Posts
its not too bad just use grease and a socket to make sure you press/tap the new one in straight. If I remember right it did not take too much pressure to seat it. here is my original post from a while back

I know this is long past the last post. I had the same problem where a fuel leak was caused at some time during the timing belt change. I'm wondering if it is caused when the seal on the High pressure fuel pump is inadvertently turned backwards a little while changing the timing belt... It could be worn in one direction and the backwards motion messes with it... remember this thing is under a lot of pressure and heat. anyways. Cheaper fix.. I just pulled the high pressure fuel pump and changed the shaft seal. From now on I will probably just change that seal preemptively as I hate doing the timing belt removal and install twice in a row. cheap insurance ... here is a link to the complete kit for replacing a bunch of parts in the fuel pump.
Seal repair kit for Bosch CP1H and CP1H3 pumps - Diesel Injection Pumps
This is a repair kit for Bosch CP1H common rail pumps. Fitted to some Iveco, Ducato, Hyundai and Opel vehicles.
injectionpumps.co.uk
injectionpumps.co.uk
Ahh OK, so you just pulled the pump off and worked on the bench to remove the pulley? How does the seal fit? I guess it may be hard to explain without pictures.

edit
Does this look like it?

 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top