Chevrolet Cruze Forums banner

EGT Fluctuating Wildly!

989 Views 5 Replies 3 Participants Last post by  Snipesy
I need some help! My EGT # 2 is fluctuating back and forth from the normal range to between -86 degrees to 2976 degrees. It will hit the top and bottom temps for a microsecond as it is fluctuating. I have replaced both sensor #2 and #3. I have the following codes - P2084, P20E2, P242B. Additionally the fluctuation is much worse with the key in the off position.

The car is running fine but won't pass emissions inspection.

Thanks for any insight on this problem.
1 - 6 of 6 Posts

· Premium Member
Joined
·
2,447 Posts
Sounds like wiring problem.

The car will struggle to perform a Regen correctly without the EGTs. But beyond that they do not affect engine operation to any noticeable degree.
 

· Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Sounds like wiring problem.

The car will struggle to perform a Regen correctly without the EGTs. But beyond that they do not affect engine operation to any noticeable degree.
I am thinking that it could be a wiring harness problem but I think it's kinda weird that it basically goes from short to open like it does
 

· Premium Member
Joined
·
2,447 Posts
I am thinking that it could be a wiring harness problem but I think it's kinda weird that it basically goes from short to open like it does

A corroded terminal will have micro arks. high current followed by no current.

If the frequency of this interferes with the ECM ADC. You get a square wave of resistance values. Which is what you are seeing.

The problem is where this ark happens. If it’s in the ECM you are pretty much SOL.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top