Chevrolet Cruze Forums banner

Engine block and Valve cover bolts rusted. Normal??

4080 Views 4 Replies 3 Participants Last post by  Blasirl
Hi,

I see half of my valve cover bolts are rusted. I only have 50K miles on my 2013 Cruze LT.

Also, I see a lot of rust build up on those bolts that hold the engine shield I think.

This looks like excessive rust for a 4 years old and 50K miles car. Should I worry? Is this normal? I need to keep this car for 60K more miles and 6 years.

Vehicle Auto part Engine Car City car
Auto part Bumper Automotive exterior Vehicle


Thank you!
1 - 2 of 2 Posts

· Administrator
2014 LT program car, Pull Me Over Red, 1.4T Auto
Joined
·
14,177 Posts
Looks pretty clean. Have you used any chemical cleaners on it? I find many items on mine that are rusting. On my 2014 LT the screws for the reverse lights were rusted to beat all **** in 2014! The dealer just shrugged at me and this was just days after I purchased it. I have since replaced them with stainless screw. All I can say is if your worried, start cleaning / de-rusting stuff now. It is only going to get worse especially if you are in the rust belt like I am.
 

· Administrator
2014 LT program car, Pull Me Over Red, 1.4T Auto
Joined
·
14,177 Posts
If you're careful on applying it, after you clean something, you can clear coat it. It will last for awhile, but not forever. A little dielectric grease on some items also works. You need to understand the effects of what you use on what parts though first.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top