Chevrolet Cruze Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Just bought this car last week figures, its under warrenty seems like it surging into gear and i decided to run the codes to see if anything was pending and its showing the P0299 underboost condition, so i got out popped the hood and it sounds like its ticking now. Does this mean im going to need a new turbo? :angry:
 

·
Registered
Joined
·
146 Posts
IT's ticking? are you sure you aren't confusing the ticking for the fuel injectors? If it's fuel injectors, there is black cylinder looking thing above the valve cover that if you squeeze you can feel the ticking vibration. The fuel injectors in our cars are loud.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
The whole engine is shaking idk. I never noticed it before yet I would thing the light would be on and it wouldn't be just pending
 

·
Premium Member
Joined
·
7,786 Posts
The service manual notes that a leak in the plumbing of the intercooler or a worn wastegate pivot pin may cause this code. Likewise any air restrictions, plugged filter, vacuum leaks, etc.

A number of people have reported worn wastegate pins necessitating replacing the turbo. I believe that's a power train item.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
I'll have to wait and see if a code sets or not. As its just pending. Car seems to sound like the "normal" sound as you guys say. But having a pending code just worries me
 

·
Premium Member
Joined
·
7,786 Posts
To run the test, the engine has to get between 2450-6000 RPM and desired boost between 19.58-31.90 PSI. The MIL won't come on until the second cycle were the test runs and fails. The MIL is turned off after 4 test cycles pass. The history is cleared after 40 warm up cycles with no problems.
 

·
Banned
Joined
·
10,296 Posts
Just had this car for a week, really no such thing as a pending code, but sure is a history code that tells the CEL was on and they reset it. With repairs, should come back.

1.4 L is a very smooth running engine, ha the first time my son rode with me, said, dad, your engine died. No it didn't, just tha quiet.
 

·
Premium Member
Joined
·
7,786 Posts
really no such thing as a pending code, but sure is a history code that tells the CEL was on and they reset it.
That's what I thought, but the manual indicates the light doesn't come on until the second time a test fails. So, I'm thinking "pending" is when the test has failed once.
 

·
Administrator
Joined
·
25,087 Posts
That's what I thought, but the manual indicates the light doesn't come on until the second time a test fails. So, I'm thinking "pending" is when the test has failed once.
As an IT professional I use a similar rule - one burp I deal with the symptom and the next time I start troubleshooting. Complexity breeds burps.
 
1 - 10 of 10 Posts
Top