Chevrolet Cruze Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2013 Cruze 1.4t and I’m getting the crank seal squeak due to high vacuum. I have replaced the valve cover when the diaphragm burst, I have installed the V2 check valve fix kit, and today I replaced the front crank seal. Despite all of this the squeal persists, at this point I’m at a loss and could really use any help or advice. Is there a component to this pcv system that I’m missing that could have failed and is causing this high vacuum?
 

·
Super Moderator
Joined
·
6,967 Posts
I have a 2013 Cruze 1.4t and I’m getting the crank seal squeak due to high vacuum. I have replaced the valve cover when the diaphragm burst, I have installed the V2 check valve fix kit, and today I replaced the front crank seal. Despite all of this the squeal persists, at this point I’m at a loss and could really use any help or advice. Is there a component to this pcv system that I’m missing that could have failed and is causing this high vacuum?
Welcome Aboard!(y)

This may sound off the wall, but make sure you spark plugs are still torqued correctly.

Don't forget to introduce yourself and your Cruze here.
 

·
Registered
Joined
·
34 Posts
Two people above have the first two things. Check your spark plug tightness, and if it stops when you pull the oil dipstick out. The other things it could be are worse. The gasket on the Valve cover has a leak (from over-tightening or no sealant around the section where the front where it joins the block), or you might need to pull the entire front assembly off and repair that gasket. If it isn't the first two I would find someone with an automotive stethoscope to hear where it is coming from.
 

·
Super Moderator
Joined
·
6,967 Posts
I forgot to mention to make sure all of the intercooler piping including the connection to the manifold is tight.
 
1 - 5 of 5 Posts
Top