Chevrolet Cruze Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter · #1 ·
Hi, please tell me more about this, I had a faulty clutch from brand new and they refused to fix it even though I was under 10k miles, and it went out at a crappy 50k.

now my new clutch which I've had for 83k miles so far gets really soft if I'm driving on the highway in 6th gear for long periods. When I go to get off or slow down I have about 50% pressure which slowly returns later. I think it has something to do with heat. This has been ongoing for 30k miles. Also it's about 75% of its original pressure overall.
 

·
Registered
Joined
·
68 Posts
Hi, please tell me more about this, I had a faulty clutch from brand new and they refused to fix it even though I was under 10k miles, and it went out at a crappy 50k.

now my new clutch which I've had for 83k miles so far gets really soft if I'm driving on the highway in 6th gear for long periods. When I go to get off or slow down I have about 50% pressure which slowly returns later. I think it has something to do with heat. This has been ongoing for 30k miles. Also it's about 75% of its original pressure overall.
My issue was only related to the lever itself. All internal clutch functions were fine... until the pedal broke enough that I had no clutch at all.
 

·
Administrator
Joined
·
25,596 Posts
Hi, please tell me more about this, I had a faulty clutch from brand new and they refused to fix it even though I was under 10k miles, and it went out at a crappy 50k.

now my new clutch which I've had for 83k miles so far gets really soft if I'm driving on the highway in 6th gear for long periods. When I go to get off or slow down I have about 50% pressure which slowly returns later. I think it has something to do with heat. This has been ongoing for 30k miles. Also it's about 75% of its original pressure overall.
Have you ever replaced the brake/clutch fluid? This should be done every 45K.

<moderator>
Moved to a new thread.
</moderator>
 
1 - 3 of 3 Posts
Top