Chevrolet Cruze Forums banner
1 - 20 of 26 Posts

·
Super Moderator
Joined
·
5,151 Posts
Discussion Starter · #1 ·
I have experienced a check engine light recently. My car runs fine and seems to shift fine in automatic mode. For some reason yesterday I got a CEL. Only after using the manumatic on the transmission. I got it yesterday for the first time and did not notice any performance/driving problems. Since I did not know of a way to check to see what codes I am getting, I decided to disconnect the battery to get rid of it and see if it would come back. It did get rid of it immediately and tonight I was driving around in manumatic and noticed it came back on. Once again I don't know how to check the codes so I disconnected again and now it is out. I drove around the block in "manu" mode but this time nothing. Nothing more than 40 MPH and shifted up to 5th gear at tops

Any ideas?
 

·
Super Moderator
Joined
·
5,151 Posts
Discussion Starter · #3 ·
Read. The. Codes.

An auto parts store will do it for free.
Didn't have time yesterday and thought I would see if anyone knew anything about it first. If it comes back again I will have them read.

Thx
 

·
Administrator, Resident Tater Salad
Joined
·
17,346 Posts
Didn't have time yesterday and thought I would see if anyone knew anything about it first. If it comes back again I will have them read.

Thx
Without them, it's anybody's guess.

Mine would be for the most common thing on Cruzes - bad valve cover.

Have a look at this guy:
 

·
Premium Member
Joined
·
8,003 Posts
I once set a CEL on my car by being too aggressive in downshifting for descending a hills. It didn't like that. That was a couple of years ago - no faults since then. (Except the time my battery died and the engine spent too long trying to crank.)
 

·
Super Moderator
Joined
·
7,794 Posts
Disconnecting the battery serves to wipe the transmission's learning of your driving style. It is not an approach I would recommend.

If you push your onstar button and ask for a remote diagnostic they will tell you your codes.
 

·
Super Moderator
Joined
·
5,151 Posts
Discussion Starter · #7 · (Edited)
Well I found out what the light was all about it was a p0299 low boost it just came on today when I was in manumatic again. Edit I just stopped to get something to eat after done I pop the hood and checked out the engine I touch one wire and no more check engine light
 

·
Registered
Joined
·
190 Posts
If you have a smart phone with bluetooth capability, I recommend getting an OBD II reader. They are as cheap as $12 on Amazon right now.

I had an intermittent problem on my last vehicle which would throw a code if it was too cool and humid during my morning commute, so I would plug the reader in, connect my phone and clear the code real quick.
 

·
Moderator
Joined
·
2,254 Posts
I highly recommend a bluetooth code reader as well. I have one in my car at all times, comes in handy and I impress all of my friends....lol
 
  • Like
Reactions: Dngrsone

·
Super Moderator
Joined
·
5,151 Posts
Discussion Starter · #10 ·
I bought a code reader and the light came back on last night and was off by this morning. If it matters: it is a constant engine light not flashing. Today I went out for a drive and the light was off most the time. Then trying to accelerate on the highway it came back on(not flashing), When I got home I read the code and I got both a P0004 and P0299. It seems rather intermittent and only after driving and making the RPM go up Last night the light came on only after climbing what we call a hill "cut in the hill" and rather steep Seems to be losing a little power but not much but the shifting seems rather delayed probably bc the loss of power? I will see if the light is off after cooling down a little.
 

·
Administrator, Resident Tater Salad
Joined
·
17,346 Posts
Don't play games with the light going on/off. It comes on if a condition is detected multiple times - the P0299 underboost code won't just stop happening on it's own - you're in need of a new turbo as the pivot pin's probably worn beyond a tolerance where the car can deal with it when it's commanding boost and isn't getting it all.

I have never seen a P0004 on these or any other car for that matter - google says it's "Fuel Volume Regulator control circuit high" and that it's not common.

Nonetheless, don't clear the codes and schedule a service appointment.
 

·
Super Moderator
Joined
·
5,151 Posts
Discussion Starter · #12 ·
Don't play games with the light going on/off. It comes on if a condition is detected multiple times - the P0299 underboost code won't just stop happening on it's own - you're in need of a new turbo as the pivot pin's probably worn beyond a tolerance where the car can deal with it when it's commanding boost and isn't getting it all.

I have never seen a P0004 on these or any other car for that matter - google says it's "Fuel Volume Regulator control circuit high" and that it's not common.

Nonetheless, don't clear the codes and schedule a service appointment.
Agreed entirely I am not going to do anything to the car till I take it in. I want to take it to the dealer but it seems by the time I get opportunity to take it the light is off(no codes as per my reader)? I am not sure if they will own up to having a problem if no codes or light. I guess I have to tell them what I experienced/read with my own reader and what Autozone read. Believe me I want to get this resolved!!! I hate driving the car and feeling like I may get run over bc of reduced power(turbo problems) and the shifting so delayed. FYI I have never seen/heard of a P0004 myself. I will take it in on Monday and I can explain the problem the best I can. FYI I am taking it to the dealer that replaced my 2012 Eco tranny as they are closest and most understanding of problems with experienced service managers.
 

·
Administrator, Resident Tater Salad
Joined
·
17,346 Posts
That's incredibly annoying when that happens. If possible, try to duplicate the conditions that seem to cause it on the trip there. Sounds like high load at moderate RPM is causing it - so lock it in manual mode and push hard on the throttle a couple times.
 

·
Super Moderator
Joined
·
5,151 Posts
Discussion Starter · #14 ·
Great idea will do hopefully it will throw a light by the time I get there.
 

·
Super Moderator
Joined
·
5,151 Posts
Discussion Starter · #15 · (Edited)
I took it in to the dealer I mentioned and they were busy today so I am scheduled for Thursday. Everything the service advisor found was looking like it was a wastegate issue but need to investigate more so that is why I am taking it back. FYI I described everything I told you guys and that is how we came to this conclusion. Hopefully it is repaired soon.
 

·
Super Moderator
Joined
·
5,151 Posts
Discussion Starter · #16 ·
Funny! Could bad gas be causing this? The last tank or 2 of 93 octane seemed to be when I got this problem. The last week or so, I have been using 89 octane and no more CEL and I even hear my turbo spooling
down in the evening and power does not seem too bad? Now kinda seems like a waste of time to take it to the dealer? Thoughts
 

·
Administrator, Resident Tater Salad
Joined
·
17,346 Posts
Funny! Could bad gas be causing this? The last tank or 2 of 93 octane seemed to be when I got this problem. The last week or so, I have been using 89 octane and no more CEL and I even hear my turbo spooling
down in the evening and power does not seem too bad? Now kinda seems like a waste of time to take it to the dealer? Thoughts
No.

Ambient temperatures may have something to do with it.
 

·
Super Moderator
Joined
·
5,151 Posts
Discussion Starter · #18 · (Edited)
I hate to say it came back again and when the car goes into passing gear it stays until @ 6K RPM. Unlike b4 the CEL was still on this morning so I think the problems coming to a head! I am definitely taking it in this week as the car has little power on the hwy.
 

·
Administrator
Joined
·
25,596 Posts
Based on your first post it could be a bad sensor. It depends on where that wire you touched goes.
 

·
Super Moderator
Joined
·
5,151 Posts
Discussion Starter · #20 ·
For whatever the problem is(felt like I couldn't get out of my own way): I took the car in this morning to get it resolved. For a loaner car they gave me a 2017 LT RS. Nice Car. Definitely different from my 2014!
 
1 - 20 of 26 Posts
Top