Chevrolet Cruze Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
1. Year 2011, trim level maybe LS (not sure), and transmission don't know.
2. Miles on the car!!! 108,505
3. Check engine light is on, I took it to Auto Zone who got the code (don't remember the code) and sold me a purge valve. The light did not go out. Since then I noticed this little wire was not connected. Is this an easy fix?
4. Near the purge valve.
)
5. See pic, this little purple wire is not connected.
6. Country! USA
7. (as needed): Left-hand drive Auto part Fuel line Tire Engine Automotive tire
 

·
Registered
Joined
·
1,082 Posts
From the picture it seems that the purple and green should be connected to that connector. The connector should be able to be disassembled and the purple reconnected, I'd use solder and be sure it's all reassembled to be water tight. If you have never done this kind of work, might consider getting some help, but anyone with some electrical experience should be able to do this repair.

Sent from my Moto G (4) using Tapatalk
 

·
Moderator
Joined
·
2,170 Posts
Hello welcome to the forum!

Was your car experiencing any symptoms when the check engine light came on? It would be really REALLY helpful to have the code that autozone read.
 
  • Like
Reactions: Tomko

·
Registered
Joined
·
1,082 Posts
If that is the wire to your purge valve, which is part of the evaporative section of emmisions on a gasoline powered car, then that wire is your problem. Code is for evaporative system purge valve: https://www.obd-codes.com/p0443

Sent from my Moto G (4) using Tapatalk
 

·
Administrator
2014 LT program car, Pull Me Over Red, 1.4T Auto
Joined
·
12,408 Posts
1. Year 2011, trim level maybe LS (not sure), and transmission don't know.
]
Welcome aboard!:welcome:

Trans is either manual or auto. Is the trim at the bottom of the windows black or chrome? Black is LS.
 
1 - 7 of 7 Posts
Top