Chevrolet Cruze Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Please can anyone help. First off 183,388 miles on my car.. its had 6 valve covers put on. Brand new Turbo replacement, let me start off by saying the reason why I took my car in to get it looked at was because of an oil smell. Now with the new turbo & 6 valve cover & gaskets replacement ( yes I said 6) now it pours out oil after you drive it, it dosnt do it while its idling..I've already stuck 1,176 $ in this car.. now my mechanic says hes frustrated with my car. & claims I need a whole new engine.. keep in mind it didnt poor oil all over my engine b4 I took it to him. Please help. Any advice..
 

·
Premium Member
Joined
·
5,305 Posts
Please can anyone help. First off 183,388 miles on my car.. its had 6 valve covers put on. Brand new Turbo replacement, let me start off by saying the reason why I took my car in to get it looked at was because of an oil smell. Now with the new turbo & 6 valve cover & gaskets replacement ( yes I said 6) now it pours out oil after you drive it, it dosnt do it while its idling..I've already stuck 1,176 $ in this car.. now my mechanic says hes frustrated with my car. & claims I need a whole new engine.. keep in mind it didnt poor oil all over my engine b4 I took it to him. Please help. Any advice..
I have some advice that you might not have thought of? I know I didn't when having a similar problem and a mechanic making it very clear Oil can start on fire while driving
 

·
Registered
Joined
·
2 Posts
Please can anyone help. First off 183,388 miles on my car.. its had 6 valve covers put on. Brand new Turbo replacement, let me start off by saying the reason why I took my car in to get it looked at was because of an oil smell. Now with the new turbo & 6 valve cover & gaskets replacement ( yes I said 6) now it pours out oil after you drive it, it dosnt do it while its idling..I've already stuck 1,176 $ in this car.. now my mechanic says hes frustrated with my car. & claims I need a whole new engine.. keep in mind it didnt poor oil all over my engine b4 I took it to him. Please help. Any advice..
Had same problem..opened hood after valve cover replaced top left bolt had oil on it..mech said somehow oil was geting thru and up bolt..they silicined and ive got no leaks
 

·
Premium Member
Joined
·
7,928 Posts
It's possible the PCV valve in the intake manifold is bad. When that goes, turbo boost goes into the engine crankcase and oil will come out any place it can. No leaks at idle (but it probably doesn't idle very well). That missing valve also blows out the PCV in the valve cover and could easily explain why you've had 6.

Go to this thread and check for the orange nub.
 

·
Registered
Joined
·
2 Posts
Please can anyone help. First off 183,388 miles on my car.. its had 6 valve covers put on. Brand new Turbo replacement, let me start off by saying the reason why I took my car in to get it looked at was because of an oil smell. Now with the new turbo & 6 valve cover & gaskets replacement ( yes I said 6) now it pours out oil after you drive it, it dosnt do it while its idling..I've already stuck 1,176 $ in this car.. now my mechanic says hes frustrated with my car. & claims I need a whole new engine.. keep in mind it didnt poor oil all over my engine b4 I took it to him. Please help. Any advice..
To be more clear i had my valve cover redone and thay mech his setup held for 45 days and it was obvious i could see the oil running down the belt side..took it somewhere else redone staryed seeing 13inxh in diameter puddles oil light came on..took back and they tracked it to there are some corners to silicone and some how mine was letting oil run up that top left bolt..he said pressure would build when pressing accel and he was able to see it piss out..go somewhere else..dude clearly isnt a customer kind of guy ..bummer i know bro
 
1 - 7 of 7 Posts
Top