Chevrolet Cruze Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey Fellas, could use a little help. I have a 2012 Cruze RS with around 55,xxx miles. All has been well with it, never any serious problems or accidents...Its ran great since day 1. This morning i hopped in to go to work and all of the warning lights came on. The message notification center told me to take to dealer to check Airbags, Brakes, and everything else you can think of. Around 7 messages of things to check. She still starts and runs just fine, but none of the gauges work. No speedometer, Tachometer, Fuel gauge or Temp gauge. Called the dealer and they want $95 an hour to troubleshoot.... Any thoughts?
 

·
Administrator
Joined
·
25,038 Posts
Negative battery cable or a dying instrument cluster. I'd try the negative battery cable first as these are symptoms of the extended warranty coverage on this cable. If your dealership insists on a troubleshooting charge for replacing a warranty item PM our Chevy Customer Care account and get them involved before taking it in.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
OberMD...Thank you for your help! The neg cable to the battery has an extended warranty on it? Or is it the negative leg that runs to the board?
 

·
Administrator
Joined
·
25,038 Posts

·
Resident Forum Drunkard
Joined
·
9,264 Posts
Yuck ity Yuck yuck another Battery cable ..

The odds have gone up exponentially for 6.000.000. cruzens to go Yuck ...
 

·
Premium Member
Joined
·
7,718 Posts
You can try the battery cable, but I'm not real hopeful. That sounds like something really went south.

Is anything plugged into your ODBII connector? Because it sure sounds like your instrument cluster can't talk to the computer it needs to talk to. The whole cluster is nothing but a glorified computer readout.
 

·
Chevrolet Customer Assistance Representative
Joined
·
5,722 Posts
Hey Fellas, could use a little help. I have a 2012 Cruze RS with around 55,xxx miles. All has been well with it, never any serious problems or accidents...Its ran great since day 1. This morning i hopped in to go to work and all of the warning lights came on. The message notification center told me to take to dealer to check Airbags, Brakes, and everything else you can think of. Around 7 messages of things to check. She still starts and runs just fine, but none of the gauges work. No speedometer, Tachometer, Fuel gauge or Temp gauge. Called the dealer and they want $95 an hour to troubleshoot.... Any thoughts?
Hey there,

I see that Obermd gave the usual shout out :goodjob:, but let us know if you need any additional assistance with this. Again, just send us a private message along with your VIN, current mileage, contact information and preferred dealership. We would be more than happy to look into this further for you.

Patsy G
Chevrolet Customer Care
 

·
Registered
Joined
·
2 Posts
Resolution?

Hey there,

I see that Obermd gave the usual shout out :goodjob:, but let us know if you need any additional assistance with this. Again, just send us a private message along with your VIN, current mileage, contact information and preferred dealership. We would be more than happy to look into this further for you.

Patsy G
Chevrolet Customer Care

What was the resolution here? I have the same issue with my car starting Sunday evening. 38,xxx miles, 3 months out of warranty, car runs but all gauges are not functioning, stereo is out, AC doesn't work, seemingly all potential warnings pop up on starting the car (side detection, air bags, etc etc). All fuses are intact. I've already had the negative battery cable replaced under that extended warranty program.


Last week (the few days leading up to the issue) the gauges would all flicker - reset to zero briefly but then they would all come back online.
 
1 - 9 of 9 Posts
Top