Chevrolet Cruze Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
8 Posts
I took my 2012 Eco in to the dealer for a leaking water pump on April 14, a month ago. At the same time the dealer replaced the electric vacuum brake assist micro switch as per the recall. When I drove the car home I noticed a new light "whirring sound" from under the hood .With my poor hearing it was only noticeable when stopped at idle but it was there all the time. I just wrote it off as maybe a "tight bearing" on the new water pump. WRONG !! The new micro switch was faulty and was running the electric vacuum pump anytime the ignition was on. I took it back and the dealer replaced the switch( a full month later) I had taken 4 1-1/2 hour trips with the pump on constantly when normally it probably only runs few seconds and maybe not very often at all on a long drive? Somewhere down the road I am sure it will fail from the misuse..
 

·
Registered
Joined
·
8 Posts
I took my 2012 Eco in to the dealer for a leaking water pump on April 14, a month ago. At the same time the dealer replaced the electric vacuum brake assist micro switch as per the recall. When I drove the car home I noticed a new light "whirring sound" from under the hood .With my poor hearing it was only noticeable when stopped at idle but it was there all the time. I just wrote it off as maybe a "tight bearing" on the new water pump. WRONG !! The new micro switch was faulty and was running the electric vacuum pump anytime the ignition was on. I took it back and the dealer replaced the switch( a full month later) I had taken 4 1-1/2 hour trips with the pump on constantly when normally it probably only runs few seconds and maybe not very often at all on a long drive? Somewhere down the road I am sure it will fail from the misuse..
More Info:: I had determined the micro switch was stuck with an ohm meter. I tapped the switch with my hand (gently) and ended up with an open circuit that now would not close (darn it). Drove the car 3 days with the pump non operational. Only had poor braking once when backing out of a parking stall. Started the car and immediately hit reverse. (no time for the engine to create much vacuum ?)
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top