Chevrolet Cruze Forums banner
1 - 20 of 26 Posts

·
Registered
Joined
·
104 Posts
Discussion Starter · #1 ·
The light popped on yesterday morning.

P21DD was its name. 41900 miles.

Dropped it off today at the dealer to get fixed along with a oil change.

Was really nice having the "special coverage" pay for the repair.
 

·
Registered
Joined
·
269 Posts
Just looked up when this happened to me. It happened last October at 40,242 miles. Must be something about these tanks and 40k miles.
 

·
Premium Member
Joined
·
4,652 Posts
Mine lasted to 191K miles. I think that's pretty unusual though. The only thing that seems for sure is that they will fail at some point.
 

·
Premium Member
Joined
·
4,652 Posts
What code is this? DEF tank?? DEF heater?
From my "common issues" thread:

Symptoms: Could be a DEF Quality poor message (P20EE) but usually a code (P21DD) for the DEF heater. Sometimes these messages are related to each other. The P21DD is more definitive.
Solution - DEF Tank Reservoir Heater – Replacement part number 23377881 (replaces 22978800). Update: In my case, it gave the DEF quality poor message but the CEL never actually lit up.
 
  • Like
Reactions: Gator

·
Reverend Red Bull
Joined
·
1,119 Posts
From my "common issues" thread:

Symptoms: Could be a DEF Quality poor message (P20EE) but usually a code (P21DD) for the DEF heater. Sometimes these messages are related to each other. The P21DD is more definitive.
Solution - DEF Tank Reservoir Heater – Replacement part number 23377881 (replaces 22978800). Update: In my case, it gave the DEF quality poor message but the CEL never actually lit up.
You can also get a P20B9 code, but that usually only comes after one of the other codes or the def quality poor message have already reared their heads.

I was just short of 60,000 miles when my DEF heater went.
 

·
Premium Member
Joined
·
4,652 Posts
You can also get a P20B9 code, but that usually only comes after one of the other codes or the def quality poor message have already reared their heads.

I was just short of 60,000 miles when my DEF heater went.
Thanks. I added that info to the common issues thread.
 

·
Premium Member
Joined
·
733 Posts
Tried to remote start my car this morning and it promptly stopped after a few seconds. I tried again and nothing. First thing that popped into my head was CEL. Sure enough, it was a CEL and it was P21DD. I'll be dropping it off after work today. Just hit 40,000km last week.
 

·
Premium Member
2014 Cruze Diesel, 2007 Cobalt, 1981 Camaro Z28, 2017 Volt
Joined
·
5,884 Posts
Our DEF heater went at a little over 44k miles - DEF Reductant Heater Low Voltage was our code, I believe.
 

·
Premium Member
Joined
·
4,652 Posts
Tried to remote start my car this morning and it promptly stopped after a few seconds. I tried again and nothing. First thing that popped into my head was CEL. Sure enough, it was a CEL and it was P21DD. I'll be dropping it off after work today. Just hit 40,000km last week.
Any speed limitation?
 

·
Premium Member
Joined
·
733 Posts
Any speed limitation?
She'll be spending the night and the day tomorrow. They said "it needs a reservoir and it'll be in tomorrow". I didn't really ask for details, but I assume that is the entire assembly it needs when the heater goes? Nonetheless, should be done tomorrow.
 

·
Registered
Joined
·
110 Posts
I had my it first CEL with my 2014 CTD a few weeks ago at 30150 miles. It turned out to be the glow plug control module... and then the dealer calls me and tells me the glow plug control module wasn't sending the right current to the DEF heater ...so...my DEF heater was replaced with the new upgraded DEF part along with a new glow plug controller module...all covered under warranty and all parts were at the dealer the next day after they were ordered....the dealer had my car for 3 days but I was issued a new 2017 Cruze to drive while my car was being repaired....can't really complain I guess...at least GM has paid some attention to the defective DEF heater with this car and has come out with a updated part and extended the warranty with this issue.
 

·
Premium Member
Joined
·
4,652 Posts
She'll be spending the night and the day tomorrow. They said "it needs a reservoir and it'll be in tomorrow". I didn't really ask for details, but I assume that is the entire assembly it needs when the heater goes? Nonetheless, should be done tomorrow.
It's the part in the middle, as I understand it, but not the entire thing.

I had my it first CEL with my 2014 CTD a few weeks ago at 30150 miles. It turned out to be the glow plug control module... and then the dealer calls me and tells me the glow plug control module wasn't sending the right current to the DEF heater ...so...my DEF heater was replaced with the new upgraded DEF part along with a new glow plug controller module...all covered under warranty and all parts were at the dealer the next day after they were ordered....the dealer had my car for 3 days but I was issued a new 2017 Cruze to drive while my car was being repaired....can't really complain I guess...at least GM has paid some attention to the defective DEF heater with this car and has come out with a updated part and extended the warranty with this issue.
I think this is only the first or second time I've heard of a faulty glow plug module. Definitely not a common issue.
 

·
Premium Member
Joined
·
733 Posts
It's the part in the middle, as I understand it, but not the entire thing.
Either way, picked her up today at lunch break and she's back to normal. Nice quick and efficient service from my dealer as usual.
 

·
Premium Member
Joined
·
4,652 Posts
Either way, picked her up today at lunch break and she's back to normal. Nice quick and efficient service from my dealer as usual.
What part number did they replace?

I'm glad to hear it's back to normal.
 

·
Premium Member
Joined
·
733 Posts
What part number did they replace?

I'm glad to hear it's back to normal.
The number of the new part you mean? Here's a pic of the relevant section of the workorder. My apologies on behalf of Imgur. They can't seem to keep my photo in landscape mode. I'd upload it here but my phone's photo size is too high and I don't feel like reformating it.
http://imgur.com/a/z5LHV
 

·
Premium Member
Joined
·
4,652 Posts
The number of the new part you mean? Here's a pic of the relevant section of the workorder. My apologies on behalf of Imgur. They can't seem to keep my photo in landscape mode. I'd upload it here but my phone's photo size is too high and I don't feel like reformating it.
http://imgur.com/a/z5LHV
Thanks, it's what i thought it was. And the formatting looked OK for me.
 
1 - 20 of 26 Posts
Top