Chevrolet Cruze Forums banner

Had some oil leaking from the left front of my car

10952 Views 24 Replies 10 Participants Last post by  fiveothis
Last week I saw some oil on the floor of my garage. It was under the left front corner of the car in front of the front wheel. Probably coming from the charge pipe connection to the intercooler. So, I took it to the dealer. At first they said there was some leakage from the valve cover. Ok, makes sense that it could be the PCV valve. They said they would replace the valve cover. Sounded like a good plan.

Then they didn't call me back when they promised. I finally got hold of them a day later and he says that called GM tech support and they think there's "too much pressure in the engine" (their words) and they want to replace the pistons and rings.

I assume they are concerned about the rings leaking and getting blow-by into the crank case. I'm a little nervous about this. I'm not entirely sure that this is the cause of the problem and haven't had any experience with this dealer before.

Any thoughts?
1 - 1 of 1 Posts

· Registered
Joined
·
9 Posts
Anyone know what other symptoms will be present if these ring lands are broken other than what the OP said about oil of his charge pipe? Will the engine burn oil internally and smoke out tailpipe or anything else like CEL??

My 2011 eco has oil on the turbo pipe to intercooler connection on the passenger side only.
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top