Chevrolet Cruze Forums banner

Has Anyone Installed an Aftermarket Radio in a 2014 Cruze?

4932 Views 10 Replies 7 Participants Last post by  johnnydio17
Hi Guys. I have a kit to install a double din radio in my 14 Cruze but it won't work properly. It either doesn't come on at all or it comes on when the car is off. Depends on the ground wire being connected or not connected to the radio chassis.

Any thoughts?
1 - 11 of 11 Posts

· Premium Member
Joined
·
311 Posts
try double checking wiring. that seems to be the issue.
 

· Resident Forum Drunkard
Joined
·
8,257 Posts
Welcome to the cruze talk Be cool stay cozy Keep Cruzen And best wishes !
Look up
2014 Chevy Cruze 1 Lt Radio Upgrade .
 

· Premium Member
Joined
·
2,240 Posts
I think you can reflash that module, I havent used the 44 yet. There should be a usb port on it. try to reflash. Ground to the chasis of the car make sure theres less than 1ohm resistance. I recommend pac-audio interfaces I made the switch because there gm harness' would do stupid crap like you describe
 

· Registered
Joined
·
4 Posts
Discussion Starter · #9 ·
When I talked with the guy at Metra/Access he mentioned reflashing the module however mine is not a USB module it is a 4 pin style. He told me I'd need an adapter. They are trying to figure out if the 14s have different wiring. They want to get a 14 for their engineers to look at. I would offer mine but they are in Florida and I'm in NY.

I looked at the PAC website but didn't see a wiring harness for my car.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top