Chevrolet Cruze Forums banner
1 - 14 of 14 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
My factory headunit (Pioneer upgrade) has just started not changing album art when the ipod changes songs, it just sticks on the 1st songs art.

I have also been through 2 sets of front door speakers in this car 2014 Cruze eco, anyone else have these issues? I dont turn volume up past 30 hardly ever.

Thanks for any help
 

·
Administrator
2014 LT program car, Pull Me Over Red
Joined
·
12,167 Posts
I suggest you find a Pioneer support forum to get better info. There may be a few people that have the unit you have, but you have to at least spell out what it is for them to know.
 

·
Premium Member
Joined
·
8,003 Posts
You might want to check the songs involved. IIRC, iTunes seems to have a "album art" that isn't always the art that's part of the track file. As such, the head unit might be looking at one thing while the iPod itself is looking at something else.
 

·
Moderator
Joined
·
10,712 Posts
Is this one of the newer generation ipods that allows you to have other apps? If so, close other apps in the background. Another option is clear and reset radio, take note your door lock settings and BT devices need to be redone again.
 

·
Premium Member
2014 Cruze Diesel, 2007 Cobalt, 1981 Camaro Z28, 2017 Volt
Joined
·
5,911 Posts
I suggest you find a Pioneer support forum to get better info. There may be a few people that have the unit you have, but you have to at least spell out what it is for them to know.
I think the OP just has the Pioneer sound option - not a Pioneer head unit. It's the same MyLink 7" unit in the dash.
 
  • Like
Reactions: anthonysmith93

·
Registered
Joined
·
132 Posts
In iTunes change to album view mode, then click on the first track of an album that is having the problem. Then right-click (or control-click on Mac OS) the song and select "Song Info". It should show the album art preview in the upper-left corner of the info window. You can then click the right arrow at the bottom-left of the info window to advance through the tracks on that album.

Check and see if it shows the same cover art or if it's only for the first track on the album. If it's only on the first track that's probably why the car head unit isn't showing it.

In that case you can select all the tracks on the album (click first track, hold down shift key and then click the last track) and then click the "File" menu, "Library" and "Get Album Artwork" to try to have it downloaded from Apple. You can then verify again using the steps above.

If you still don't have the artwork shown for each track you can click the first track that does have it, right-click and select "Song Info". Click on the cover art in the upper-left of the window and iTunes should show a selection outline. Go to the "Edit" menu and select "Copy". Then repeat the steps to select all the tracks on the album, then with all of them selected (highlighted) right-click on one of them and click "Get Info". Click the cover art icon/graphics in the upper-left so it has the selection outline, then go to the "Edit" menu and select "Paste".


Some media players including in-car systems are compatible with iTunes libraries on iPods and iPhones and will know to display the same cover art on the first track for all of the tracks on the same album, but many others won't. For example I have an ancient touch screen iPod that won't do this on the iPod itself. Using the steps above will copy the cover art into each individual .mp3/.aac file.

Also if you're manually scanning or downloading cover art from the internet (such as Album Art Exchange) for albums that Apple doesn't provide, make sure not to select too high of a resolution (in pixels, such as 1000x1000 instead of 600x600, for example).

Pioneer has nothing to do with the head unit in the Cruze as they only provide the speakers so this isn't directly related, but I have a Pioneer home A/V receiver that uses Apple's AirPlay and will crash when the cover art is too big. Probably not the case with the Chevy MyLink head unit but something to keep in mind if you do collect your own cover art and use really big files. There's a chance giant cover art might no display correctly in MyLink.


As to your speaker problems in the front doors how exactly are they failing? It could be anything from manufacturing defects on the stock speakers, a poor wiring connection that damaging them, to possibly bad weather sealing in the door allowing water/moisture to damage them. If you play a lot of lower resolution (quality) compressed media like MP3s and the gain (loudness) is poor on the track and the speakers clip, even at lower volumes that could cause damage over time.
 
  • Like
Reactions: Taxman

·
Administrator
2014 LT program car, Pull Me Over Red
Joined
·
12,167 Posts
I suggest you find a Pioneer support forum to get better info. There may be a few people that have the unit you have, but you have to at least spell out what it is for them to know.
I think the OP just has the Pioneer sound option - not a Pioneer head unit. It's the same MyLink 7" unit in the dash.
I thought that might have been a possibility, so that is why I also asked the OP to spell out what they have.

EDIT: It looks like the question was edited for clarity as well now.
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #8 ·
I apologize for any confusion, it is the factory headunit with the pioneer upgrade with my link.

The ipod is actually an iphone 6s plus.

I have all ablum artwork downloaded to all songs, the first song that comes up is fine on both the ipod/iphone and the my link display, the next song the artwork changes on the ipod/iphone but not on the my link display, the min/second counter is changing and working it just contiues to display the artwork from the 1st song, if I go into the headunit and change source to FM then back to ipod the artwork displays correct... but again next song its still on whatever was up last from the source change... during all this the artwork on the ipod/iphone is changing and displaying correct.

Hope this helps and thank you all for your assistance!
 

·
Registered
Joined
·
132 Posts
If you're changing to a different album and it keeps displaying the other cover art, I usually have that happen occasionally on the 1st generation Cruze MyLink when I use my 64GB iPod Touch with 12k+ songs. The system takes forever to index and there's sometimes a delay in the cover art being displayed on track change.

That doesn't sound like the case for your car if it gets "stuck" and never changes unless you change source like you're describing. If you haven't already tried it you might consider unplugging the negative battery cable for a couple minutes, then plug back in which should reset the MyLink system and see if there's any change in behavior.

Unfortunately Chevy and GM originally advertised that there would be software updates that end-users would be able to download and install via a USB memory stick but that never came to be. If your MyLink head unit isn't running the latest software the only practical way for most people to get it is a visit to the dealer. If you're not under bumper-to-bumper warranty this may cost an hour or two of labor.

If a system reset doesn't work the other thing to rule out would be your iPhone. If you're iTunes library isn't massive, you could try copying it to a USB memory stick and see if the behavior stays the same. Or if you have someone else in your household with a different phone have them try connecting and see if there's any change.
 

·
Moderator
Joined
·
10,712 Posts
If you're changing to a different album and it keeps displaying the other cover art, I usually have that happen occasionally on the 1st generation Cruze MyLink when I use my 64GB iPod Touch with 12k+ songs. The system takes forever to index and there's sometimes a delay in the cover art being displayed on track change.

That doesn't sound like the case for your car if it gets "stuck" and never changes unless you change source like you're describing. If you haven't already tried it you might consider unplugging the negative battery cable for a couple minutes, then plug back in which should reset the MyLink system and see if there's any change in behavior.

Unfortunately Chevy and GM originally advertised that there would be software updates that end-users would be able to download and install via a USB memory stick but that never came to be. If your MyLink head unit isn't running the latest software the only practical way for most people to get it is a visit to the dealer. If you're not under bumper-to-bumper warranty this may cost an hour or two of labor.

If a system reset doesn't work the other thing to rule out would be your iPhone. If you're iTunes library isn't massive, you could try copying it to a USB memory stick and see if the behavior stays the same. Or if you have someone else in your household with a different phone have them try connecting and see if there's any change.
Updates seem to temporarily break the iPhone and MyLinks compatibility at times. GM used to sent out pointless PI#'s that simply said "we are working on it" Also playlist that exceeded 25 songs wreak havoc on the system as well. it got to the point I only used USB sticks to play music. Glad the OP got it working again.

My Accord iMid system is even more Anti Apple until you get the HondaLink in the higher trims. Hands free is pointless and reply to txt doesn't work. I used windows and droid phones and the system worked as advertised. Went back to USB stick again.
 

·
Registered
Joined
·
132 Posts
While the first gen MyLink has some quirks I like the interface quite a bit. I had a '13 Focus ST for a couple years right after they came out and cursed daily at the MyFord Touch (Sync 2) interface. If I wanted to browse and find a specific album on my iPod I could argue with the voice recognition system for twenty minutes or punch the screen and waste time. Surprisingly the best Apple and iPod integration has been with the Microsoft Windows Mobile/Embedded (CE-based) touch interface on my second generation Cadillac CTS. It's structured and works similar interface-wise to the older iPods and music app on the older iPhones.
 

·
Moderator
Joined
·
10,712 Posts
While the first gen MyLink has some quirks I like the interface quite a bit. I had a '13 Focus ST for a couple years right after they came out and cursed daily at the MyFord Touch (Sync 2) interface. If I wanted to browse and find a specific album on my iPod I could argue with the voice recognition system for twenty minutes or punch the screen and waste time. Surprisingly the best Apple and iPod integration has been with the Microsoft Windows Mobile/Embedded (CE-based) touch interface on my second generation Cadillac CTS. It's structured and works similar interface-wise to the older iPods and music app on the older iPhones.
Did Cue make it to the 2013 MY if that's what you had? 13 was a horrible year for CUE and MyLink. Mosty Cue with navi were the worst complaints.
 

·
Registered
Joined
·
132 Posts
My second (last) generation '14 CTS-V didn't have CUE, which was introduced on the 3rd (current) generation regular CTS models which confusingly were introduced in the same model model year the old -V cars were still being built. The graphics on the pre-CUE interface are blocky and it's a pretty basic for features but does a great job of sorting and finding music in a large library.


I've driven and used CUE in a couple newer Cadillac models and it's not terrible but responds really slow. Not having any physically knobs for things like volume bothered me quite a bit. The upgraded CUE hardware which is the basis of the newer MyLink systems in the new Cruze and other GMs responds quite a bit better and they've fixed a lot of the interface clutter.


My '14 Cruze diesel used the same Panasonic-based system as the '13 cars if I recall correctly. I don't have navigation but rather like the standard MyLink from a music playing standpoint and being able to use the physical select/enter/back buttons along with the touchscreen.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top