Chevrolet Cruze Forums banner
61 - 76 of 76 Posts

·
Registered
Joined
·
14 Posts
CEL came back on 5 miles after leaving the dealership. (shocker) Now they are saying it needs another EGR cooler.

I did not ask about the release date for the latest update, it didn't fix anything.
 

·
Registered
Joined
·
1,908 Posts
Discussion Starter · #62 ·
CEL came back on 5 miles after leaving the dealership. (shocker) Now they are saying it needs another EGR cooler.

I did not ask about the release date for the latest update, it didn't fix anything.
Hard to guess with your car but my best guess would be the mechanic saw the firmware update I mentioned with the recall to fix the issue where the CEL wouldn't illuminate with certain problems, and they thought that new firmware version would fix your problem.
 

·
Registered
Joined
·
1,908 Posts
Discussion Starter · #64 ·
It’s back again today with the three codes set:
P0401
P0403
P0405

This time the light came on the instant I started the car this morning. It didn’t illuminate in the middle of a drive - started and came right on.
 

·
Registered
Joined
·
1 Posts
yes. it is topside and easy to change the egr valve. I looked at the instructions on alldatadiy.com a while back - factory service manual info is on-line. The egr cooler on the other hand - that looked like a bit more work.

send me a private message with your e-mail and I can print out the instructions and send them to you.

If you have trouble finding an egr valve - I have a new one in the garage.

jeff
HI, I have this problem. P0401. I want to extract and clean the EGR valve.

Could I have a copy with the instructions? Thanks

[email protected]
 

·
Registered
Joined
·
386 Posts
I had a TC show up, egr cooler efficiency didnt write it down. I looked at the intake hoses and both were a little loose, one was 1/8 and the other about 1/2 a turn. I tightened them up did a regen and drove around for an hour at 2000 rpm. It has not came back on. I think our cars are sending a lot of extra fuel in our engines even if there just a small air leak. Seems like a terrible thing to do. Will have to check my intake hoses on a regular basis permanently.
 

·
Registered
Joined
·
1,908 Posts
Discussion Starter · #73 ·
The light was on again today. Around 4am I had to relocate a raccoon I trapped at my parents' house and it turned on when driving the guy to his new home.

Vertebrate Carnivore Pet supply Mammal Felidae


By this afternoon, when taking my mom on errands to a hair appointment and other things, it was off again.
 

·
Registered
Joined
·
1,908 Posts
Discussion Starter · #74 ·
Fun times this week. The morning of the 7th I had to relocate another raccoon I trapped. I backed the car out of the driveway and shut it off. By the time I got the trapped trash panda in the trunk I got an email from OnStar saying the emissions system needed servicing. Driving the car around that day resulted in nothing happening.

Then, today, the CEL comes on this morning. It's like I got a full 24-hour notice via email that the CEL was going to illuminate!
 

·
Registered
Joined
·
1,908 Posts
Discussion Starter · #75 ·
The light is back on again today! This was after driving through what was easily the biggest rain storm I've ever seen in my life (lots of roads and intersections flooded to about a foot deep of water). Today it was humid and I've noticed that after driving the car in very wet/humid weather, the light comes on. I think there is soot throughout the EGR system and when it's wet/humid the soot gets all chocked up and turns the light on. After some days of driving when it's hot weather to dry it out, the light goes off.
 

·
Registered
Joined
·
1,908 Posts
Discussion Starter · #76 ·
And now the light is off today. Doing more driving in hot weather has basically dried the car out and I think the soot is back to being dry and not clogging whatever is gumming up the EGR valve.
 
61 - 76 of 76 Posts
Top