Chevrolet Cruze Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter · #1 ·
Hi, I'm Jay. As the title read, I will have had my '12 LS for one month this Thursday. I haven't decided on a name, but I know she's a woman haha.

She is Ice Blue Metallic with lame shiny wheel covers(I desire 1LT wheels), all cloth, black/grey/silver on the inside.

I love the manual trans. Shifts smooth with GREAT clutch feeling. I absolutely love seeing 42+ mpg on the highway, around 19-26 city, depending upon speed/hills/etc. She's an improvement over my '05 Chrysler Town & Country, which I traded for her.

I will be putting in my head unit, amp and subs as soon as I test some theories about this horrible factory stereo. Kinda irked, GM. Kinda. Irked.

Pics in my Garage link, more and plans coming soon.

Have a good day, everyone!

--Posted from My Lab In Space, Android 5.1.1--
 

·
Moderator
Joined
·
2,170 Posts
Welcome to the forum! Excellent upgrade & downsize from the Town and Country to the Cruze. That gas savings has got to be noticeable. Gotta agree with you on the hubcaps though. Looking forward to the pictures and updates. Have a great day!
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #5 ·
Thanks, chevrasaki! I can't get over the fuel mileage! I can go ~ 1 1/2 weeks on a tank! If I keep my foot out of it, that is! Haha.

Cheers! I'm about to go take my dash apart and test if everything(minus OnStar & chimes, which can both go away) works with the factory radio & screen completely unplugged. I haven't found much info on this topic. It's part of my wild plan to give GM the middle finger lol.


--Posted from My Lab In Space, Android 5.1.1--
 

·
Premium Member
Joined
·
25,596 Posts
Welcome to Cruzetalk.
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #9 · (Edited)
Thanks to all!

Suspicions confirmed! I unplugged the factory radio & infotainment screen. All interior/exterior lights remain functioning, as well as all functions of my key fob. The car didn't wig out when I started it without the radio.

SO. I plan to use inline splicers to splice my Kenwood's harness into the speaker and +12v wires of the factory harness, right where it plugged into the original radio. I will get my Ignition lead from either the cig lighter OR buy an add-a-circuit. The add-a-circuit would make it easier to run both the Amp Remote and Head Unit turn on.

Ordering the dash kit and away we go!

--Posted from My Lab In Space, Android 5.1.1--
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top