Chevrolet Cruze Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I need help figuring out what the issue is with my 3rd brake light. I have a 2012 chevy cruze eco MT and my third tail light has started flickering every half second when I apply the brakes. I'm guessing I'm going to get pulled over soon, so I should probably get it fixed. Here are the facts:

- Both brake lights work just fine. All other lights in the car work fine.

- The flickering is very rapid. It sometimes slows down a bit, but that's rare.

My guess is that a fuse is blown, but from what I read online, this may not be the issue.

Thank you for the help!
 

·
Administrator
Joined
·
25,603 Posts
Did someone install a flicker circuit in your third brake light? I ask because I have one of these and it causes this one light to flicker for a couple of seconds when you first press the brake pedal. If you have this circuit it could be failing. Another possibility is a loose connection.
 

·
Resident Forum Drunkard
Joined
·
9,297 Posts
Open trunk . Loosen the 2 bolts that hold the 3rd brake light in place .
Inside the back seat remove the 3rd brake light carefully seperating the power supply connection . Examine the attachment points for corrosion .

Find a pencil eraser to use to clean the contacts on the 2 conection points .
Reconnect the power supply wires to the 3rd brake light and test the operation of said brakelight ..

You can always leave it off if IT does not work properly or until you are able to fully trouble shoot the fault .
 

·
Registered
Joined
·
6 Posts
I have the same problem, but it only flickers when the engine is running. It also does not start flickering for the first 2 seconds after the brake pedal is depressed. I checked the alternator and it's working correctly (voltage test at the battery is 14.5). I cleaned the wire contacts at the light mostly because I couldn't think of anywhere else to look.
 

·
Premium Member
Joined
·
8,003 Posts
The whole thing or part? It could be something failing. LEDs can fail. Engine running => higher voltage => LED acts up. The first that it's working when first turned on is consistent with that.

You might look into pulling a unit from the junkyard.
 

·
Registered
Joined
·
1 Posts
This happeneds Take me too, my third brake light start flickering Whenever I press the break. the other two brake lights are ok though! Welp
 
1 - 6 of 6 Posts
Top