Chevrolet Cruze Forums banner
1 - 9 of 9 Posts

Registered
Joined
3 Posts
Discussion Starter · #1 ·
Help me please I have a 2013 chevy Cruze LTZ RS and it won't start when I push the start button everything just goes dead and all lights on the dash are on and off.
I have checked all fuses and everything. Does anyone have any Idea what going on with my Cruze?
 

Registered
Joined
3 Posts
Discussion Starter · #3 ·
Help me please I have a 2013 chevy Cruze LTZ RS and it won't start when I push the start button everything just goes dead and all lights on the dash are on and off.
I have checked all fuses and everything. Does anyone have any Idea what going on with my Cruze?
Help me please I have a 2013 chevy Cruze LTZ RS and it won't start when I push the start button everything just goes dead and all lights on the dash are on and off.
I have checked all fuses and everything. Does anyone have any Idea what going on with my Cruze?
Help me please I have a 2013 chevy Cruze LTZ RS and it won't start when I push the start button everything just goes dead and all lights on the dash are on and off.
I have checked all fuses and everything. Does anyone have any Idea what going on with my Cruze?
Help me please I have a 2013 chevy Cruze LTZ RS and it won't start when I push the start button everything just goes dead and all lights on the dash are on and off.
I have checked all fuses and everything. Does anyone have any Idea what going on with my Cruze?
Have you had the battery tested?
Yes, the battery is good.
 
1 - 9 of 9 Posts
Top