Chevrolet Cruze Forums banner

Help! Service Stabilitrak/Service Power Steering/Service Traction control/low power

78799 Views 17 Replies 13 Participants Last post by  Cruzissues2023
Hi all, at my wits end trying to figure this out. I'm sure its something simple, at least I hope!

2013 Cruze LS 1.8, Auto, 75K.

For about the last month, occasionally after starting, my Service Stabilitrak, Service Power Steering, and Service Traction Control lights all come on, warnings come on the screen in that order. This is happening since its been cold. A few times when this has happened, I haven't been able to get it out of park. The selector moves, but the transmission does nothing. When it does go into gear, it "clunks" into gear, and the car is in low power mode. If I drive or idle for 5 minutes or so, I can turn the car off, wait 30 seconds, and turn it back on and all the warning lights will be off, and I can drive the car as normal. (Check engine light stays on). This can happen a few days in a row, or 4-5 days in between, and only happens either overnight or after work- when the car has been sitting for a while. NEVER happens when running errands with multiple starts.

I checked all over, and found that it might be the negative battery cable, which there was a recall for, so I replaced the cable with a new AC Delco cable. The explanation was there was not enough voltage (Bad Ground) going to the computer when starting, which caused the error codes. Once the battery got charged for from a few minutes of driving, there was enough voltage at start to not cause the error. I thought that fixed the issue, but it started happening again about 4 days later.

I don't think it is the battery itself- Before starting, on a cold morning, my multimeter it giving me 12.25-12.5 volts, and the battery is only about 6 months old.

I ran the code, and am getting U0101, $07E8, "lost communication with TCM", which when I researched, looks like I'm getting pointed back in the direction I started from- Not enough voltage causing a glitch in communication when starting.

My Alternator is good, cable and ground is good. Anybody have this same issue? I've found a few threads with similar issues, but nothing quite like this, with all three service codes + loss of power.
See less See more
1 - 1 of 18 Posts
So, It happened to me again. This time was worse then the others. Got off work, 3 AM. It very cold, colder than any night in the last few weeks of having this issue. (40 degrees on my display) I start the car- Starts fine. Battery sounds good, volts are good on display (13v+) All three warning lights come- Service traction control, service power steering, service stabilitrak, along with the check engine light. Car is running and sounds fine. I try to shift into gear, and the shifter moves, but does not actually go into any gears.

On other cold mornings, with the service lights coming on, the same thing has happened, or I have been able to get it into limp mode so the car will at least move. After either driving the car to the nearest gas station ( a few miles) or letting the car run for a few minutes (5 minutes or so) , I have been able to turn the car off, let it sit for 30 seconds, turn it back on, and it runs fine- all service lights will be off.

On this particularly cold night, this "trick" of letting the car warm up for a few minutes didnt work. After about 30 minutes of the car being on and trying to restart it to get the problem to go away, I decided I needed a tow home. Turned it off, called the tow company. No answer. I decided to try the car one more time before calling another tow company. Low low and behold, car went into gear, everything is fine, and I got it home. I guess it didnt like being threatened with a tow!

Continuing, I woke up in the morning- 9 AM- 5 hours after I got it home. Still pretty cold out, 50 degrees or so, to get the car down to the mechanic for a professional diagnostic. The shop is about a mile away. Start the car, put it in gear, and everything is fine. Drive about 1/2 way there, and the car goes into limp mode. get it to the mechanic, and describe all my issues.

Update to today, and called the mechanic for an update. He is still trying to diagnose the problem, but its not looking good. The CEL code is U0101, lost communication with TCM. He says he checked the obvious things - Battery, Etc. Battery good. (Less than 1 year old) Recalled negative cable good ( I just replaced it ). He says he has checked for service bulletins or recalls that may pertain to this issue. When he hooks up his scanner, he can communicate with the TCM and all signs say its good. He can communicate with the ECM, and all signs say its good, and when he looks at the ECM, he says it shows that communication between the ECM and TCM is normal as it should be. Basically, ECM and TCM are communicating fine, but ECM is sending the code that they are not communicating fine, and throwing the service codes and putting the car into limp mode by either not letting me go into gear at all, or limiting power.

So at this point, he says he is going to look at a few more things, but the next step would be reprogramming the computer and "Hope" that works. Not exactly promising. Doesn't seem to me that software would be affected by the cold weather, but who knows. It seems to me it might be more of a hardware issue with the ECM or TCM, meaning that the cold weather makes a connector or chip in the computers shrink just enough to lose contact, and that when warmed slightly, contact is made again, letting the car run fine.

Not sure what to do here- I don't want to just throw spaghetti at the wall and see if it sticks. Flash or replace the ECM (mechanic seems knowledgeable) or take it to the dealer? (Which I try to avoid!)
Had the exact same lights followed by limp mode and the TCM fixed it. 2.5 labor hours, transmission fluid and the charge for programming it and it’s good. I bought the AC Delco TCM myself so I didn’t pay too much! Drove it 600 miles on a trip the next weekend and now have about 1,000 miles over last 3 weeks and no issues!!!
1 - 1 of 18 Posts