Chevrolet Cruze Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter · #1 ·
I have 2014 LT2 RS with the all weather rubber mats installed. A month or so ago, I noticed water on the passenger front mat after a hard rain. I pulled the mat out and the carpet is dry. 3 different times so far. So I am assuming the water is dripping from the dash and not firewall.

I did find the drain outlet flap on the firewall was clogged. I cleaned it out and ran water on the windshield and the water flowed out the drain flap just fine. I thought my trouble was over.

Then a day ago, the snow melted off the car and I used it to go up the street. I looked over and water on the mat again. More than ever this time.

Any ideas here? Is there a common fix here?

Thanks, James
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #5 ·
Well the first dealer I stopped by to make an appointment didn't go well. I showed them the TSB and I think they took offense that I had information they knew nothing about. With their attitude, I decided to go elsewhere.

Second dealer I went to welcomed the information and I made an appointment. They checked out the car and decided that the TSB was on target and ordered the parts. Since then I have had the car back and they made the repair but it hasn't rained yet. Time will tell.

Thanks for the info guys. James

PS The Service Writer made it sound like the Cruze was supposed to have the deflector and some cars made it off the line without it.
 
1 - 3 of 3 Posts
Top