Chevrolet Cruze Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
I installed my winjets a few weeks back, and last night my drivers side headlight went out, no low or high beam, I checked the plugs, no issue there, looking for any help, Please, one headlight really sucks
 

·
Banned
Joined
·
10,296 Posts
One of these?



Dual filament 55W lamp, same wattage as OE, claims to be a much brighter H7 lamp. Is helpful to have a lux meter and a 12V power supply to compare the light output current and voltage with the original to learn if its both operational and is actually putting out more light than the OEM. Just looking at the filaments doesn't tell if they are good, also interconnections in these things.

Like to do this before replacing any bulb, saves the work of installing a bad bulb. Also have a fuse and a relay in the under hood fuse/relay box, under the cover tells you where they are located.

Also claim professional installation may be required if you can find a certified light bulb installer.
 

·
Premium Member
Joined
·
8,003 Posts
I installed my winjets a few weeks back, and last night my drivers side headlight went out, no low or high beam, I checked the plugs, no issue there, looking for any help, Please, one headlight really sucks
Low beam and high beam are completely separate circuits. My guess is that you have either a bad bulb or a bad ground on that headlight.
 
  • Like
Reactions: Blasirl

·
Registered
Joined
·
17 Posts
Discussion Starter · #5 ·
Bad ground? Would it be a bad ground through the factory harness?
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #6 ·
Do the blinkers work ? Just the halogen or do you have an aftermarket bulb as well?

11 Cruze LTZ 1.4T
04 Ranger XLT 4.0 4x4
Blinkers work, I have the stock bulb that came in the headlight installed still.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #9 ·
I figured it out!! Turns out when I installed the headlights I pinched 2 wires which stripped the insulation off and grounded the light out, once I pulled them out the light is working again. Thanks for all the input!!!
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top