Chevrolet Cruze Forums banner
1 - 19 of 19 Posts

·
Registered
Joined
·
152 Posts
Discussion Starter · #1 ·
2012 LTZ 45k miles on 3rd water pump.

Another water pump about to fail? Sprayed belt with water made no difference, not overheating, coolant temps normal, engine bay has always smelled of coolant. No leaks visible.
 

·
Registered
Joined
·
152 Posts
Discussion Starter · #3 ·
I have, long before the whine began... just don't want her to be stranded, anyone had this whine prior to failure?
 

·
Registered
Joined
·
152 Posts
Discussion Starter · #5 ·
You only had audible noise and no leak from the weep hole? It's still functioning correctly.
 

·
Administrator, Resident Tater Salad
Joined
·
17,545 Posts
You only had audible noise and no leak from the weep hole? It's still functioning correctly.
A whine or squeal is often the first sign of a water pump starting to fail.

Whatever shop keeps throwing water pumps at this car REALLY needs to look into the tension or tensioner on the serpentine belt.
 

·
Registered
Joined
·
152 Posts
Discussion Starter · #7 ·
A whine or squeal is often the first sign of a water pump starting to fail.

Whatever shop keeps throwing water pumps at this car REALLY needs to look into the tension or tensioner on the serpentine belt.
The previous 2 pumps were replaced prior to our ownership, but i'll mention it to the dealer... this thing was supposed to be a cheap fuel sipper, it's becoming annoying already.
 

·
Registered
Joined
·
152 Posts
Discussion Starter · #12 ·
it's 20f here and noise not evident nor is the smell in the engine bay, I guess i'll bring it in when it gets warmer and reoccurs
 

·
Registered
Joined
·
152 Posts
Discussion Starter · #13 ·
She drove it in traffic an extended amount of time today, smell and whine were back as she pulled into the driveway. Coolant Is dripping down the block so looks like time for water pump #4. Unbelievable.
 

·
Registered
Joined
·
152 Posts
Discussion Starter · #15 ·
Brought It in today was given a 2014 lt its much quicker in acceleration for some reason, what else is wrong with our 12 :/
 

·
Registered
Joined
·
152 Posts
Discussion Starter · #17 ·
Was 2014 pcm updated?
 

·
Registered
Joined
·
3,340 Posts
Mine is a diesel so I'm not sure. There were a lot of problems fixed and issues eliminated for the 2014 so I wouldn't be surprised.


Sent from the sexy electrician
 

·
Registered
Joined
·
152 Posts
Discussion Starter · #19 ·
shows about 11psi under full boost, slow, no codes, still smell coolant in the engine bay after it reachs op temp... cool car.
 
1 - 19 of 19 Posts
Top