Chevrolet Cruze Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
I registered just so I could say Thank You!
Took me 2 half days, I let the epoxy set up over night. No more engine light! Runs great! 6 valve covers and three intake manifolds, I’m not paying Chevrolet for any more!
 

·
Registered
Joined
·
3 Posts
After a 120 mile round trip today the oil pressure light came on telling me to shut the engine down. Three quarts blew out all over the right side of the engine compartment. Either my valve cover gasket blew on its own or the check valve isn’t releasing the pressure and blew the gasket out. Guess I’ll be back under the hood this weekend. I’m thinking faulty or clogged check valve. I hope I’m wrong.?
 

·
Registered
Joined
·
3 Posts
I don’t know what happened to my second post, it doesn’t seem to be on the page. I was hoping you guys would have some advice. I installed v1 kit with bnr spacer. Ran great for one day, no engine light. Third day I put 120 miles on it and it blew out three quarts of oil (I think from valve cover but not sure.) I know I didn’t install valve backwards. Do you think I got a faulty check valve? Or maybe my valve cover gasket just failed. I’m going to pull the check valve and test it this weekend. I guess I’ll order a new valve cover gasket tonight and replace that too. If i can’t fix it I’ll have to go back factory, I don’t want to do that! Any advice appreciated.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top